Ticket #1605 (reopened defect)

Opened 9 years ago

Last modified 3 years ago

Incorrect parsing FTP-string

Reported by: Hubbitus Owned by: slavazanko
Priority: major Milestone: Future Releases
Component: mc-vfs Version: 4.7.0-pre2
Keywords: Cc: onlyjob@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

ENTRY "example.net" URL "/#ftp:examplenet:5wDJP1B/y@example.net"

When I try connect to it I saw:
"ftpfs: making connection to examplenet"
off course this is failed by timeout.

Change History

comment:1 Changed 49 years ago by slavazanko

  • Blocked By 2361 removed

(In #2361) Merge changeset:f2ebbd2eb4bd9e196963ecaf1f79b31986ad64ac

For getting list of commits in branch type:

git log --pretty=oneline fcfa76b..ef676d3

comment:1 Changed 9 years ago by slavazanko

  • Owner set to slavazanko
  • Status changed from new to accepted

comment:2 Changed 9 years ago by slavazanko

Created branch 1605_incorrect_parsing_ftp_string

Initial changeset:4461cbc55829af3f8cc24611c4a865d12e82c8c4

Review, please.

comment:3 Changed 9 years ago by slavazanko

  • severity changed from no branch to on review
  • Milestone changed from 4.7 to 4.7.0

comment:4 Changed 9 years ago by angel_il

need search last entry of symbol "@", for correct recognize password with "@" inside. Like this: "/#ftp:examplenet:5@@JP1B/y@example.net"

comment:5 Changed 9 years ago by angel_il

  • severity changed from on review to on rework

comment:6 Changed 9 years ago by slavazanko

  • severity changed from on rework to on review

review.

comment:7 Changed 9 years ago by angel_il

  • Votes for changeset set to angel_il

comment:8 Changed 9 years ago by metux

  • Votes for changeset changed from angel_il to angel_il metux

should it be rebased (and maybe squeeze the two commits) before merge ?

comment:9 Changed 9 years ago by metux

rebased it to current master,
please have a quick look at 1605_incorrect_parsing_ftp_string_REBASED before merging it.

comment:10 Changed 9 years ago by slavazanko

Of course, branch need to rebase. But decision of rebasing is taken by the owner of the branch.

Don't worry about rebasing - you may reminder about this into comments into ticket. No need to create new branch.

Also, branch stay into 'on review' status. Is need for third vote to this branch or you just forgot to change status to 'approved'?

comment:11 Changed 9 years ago by andrew_b

  • severity changed from on review to approved

comment:12 Changed 9 years ago by slavazanko

  • Status changed from accepted to testing
  • Votes for changeset changed from angel_il metux to commited-master
  • Resolution set to fixed
  • severity changed from approved to merged

comment:13 Changed 9 years ago by slavazanko

  • Status changed from testing to closed

comment:14 Changed 9 years ago by andrew_b

  • Blocking 1941 added

(In #1941) This bug is introduced in #1605.

comment:15 Changed 9 years ago by andrew_b

  • Blocking 1947 added

(In #1947) I beleive this is relative to #1605 and #1941

comment:16 Changed 9 years ago by slavazanko

  • Status changed from closed to reopened
  • Votes for changeset commited-master deleted
  • Resolution fixed deleted
  • severity changed from merged to no branch
  • Milestone changed from 4.7.0 to VFS Standardization

Need to revert patch applied in this tickect and need to completelly rework VFS stuff.

This ticket moved into 'VFS standartization' milestone

comment:17 Changed 9 years ago by slavazanko

  • Blocking 1941, 1947 removed

master revert: 8689d6a925e5606009267646f0d608e1db31873b
4.7.0-stable revert: 229c2a17e36486e66ec77531f76e2c99612e9dd0

Ticket stay reopened until complete 'VFS standartization' milestone

comment:18 Changed 9 years ago by andrew_b

  • Blocking 2220 added

comment:19 Changed 8 years ago by andrew_b

  • Blocked By 2361 added

comment:20 Changed 7 years ago by andrew_b

  • Blocking 2220 removed
  • Branch state set to no branch

Was it fixed as a part of #2361?

comment:21 Changed 3 years ago by andrew_b

  • Milestone changed from 4.8 to Future Releases

comment:22 Changed 3 years ago by andrew_b

Ticket #3552 has been marked as a duplicate of this ticket.

comment:23 Changed 3 years ago by onlyjob

  • Cc onlyjob@… added

comment:24 Changed 3 years ago by andrew_b

Ticket #3633 has been marked as a duplicate of this ticket.

comment:25 Changed 3 years ago by zaytsev-work

Note that Ticket #3552 has a patch for URL-encoding the thing, which might be one approach to solve the problem.

Note: See TracTickets for help on using tickets.