Ticket #3552 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

Cannot login to ftp server with USER = webmaster@domain

Reported by: onlyjob Owned by:
Priority: major Milestone:
Component: mc-vfs Version: 4.8.13
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

As reported in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=800915

It may not be possible to log in to FTP server with name like "webmaster@…" due to improper handling of '@' character which should be escaped as "%40".

Attachments

800915-mc-url-unescape.patch (2.7 KB) - added by onlyjob 4 years ago.
proposed patch

Change History

Changed 4 years ago by onlyjob

proposed patch

comment:1 Changed 4 years ago by and

To make mc fit for rfc3986 we should handle all related uri fields.

an sanity check must follow after each unescape() to prevent
bad things (TM) with decoded control characters.

comment:2 Changed 4 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate

Closed as duplicate of #1605.

comment:3 Changed 3 years ago by andrew_b

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.