Ticket #1606 (closed defect: worksforme)

Opened 10 years ago

Last modified 22 months ago

with ncurses interface, page down in directory hotlist deletes entry

Reported by: snzzbk Owned by:
Priority: major Milestone:
Component: mc-tty Version: 4.7.0-pre2
Keywords: Cc: snzzbk@…
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

When using the ncurses interface, pressing page down in the directory hotlist deletes the highlighted entry. Page down works normally in the main window and the command history window with ncurses and also in the directory hotlist when using slang.

Change History

comment:1 Changed 10 years ago by snzzbk

  • Cc snzzbk@… added

comment:2 Changed 10 years ago by andrew_b

Cannot reproduce.

Please provide the detailed info about your OS, terminal emulation program, MC version, NCurses version.

comment:3 Changed 10 years ago by snzzbk

I'm using Gentoo Linux AMD64, mc 4.7.0-pre2, and ncurses 5.7. The behavior is the same in rxvt-unicode and the Linux console.

comment:4 Changed 10 years ago by iNode

Reprodyceable, in xterm/rxvt-unicode.

$ mc -V
GNU Midnight Commander 4.7.0-pre2-131-g1899f9b
Virtual File System: tarfs, extfs, cpiofs, ftpfs, fish
With builtin Editor
Using the ncurses library
With support for background operations
With mouse support on xterm
With support for X11 events
With internationalization support
Data types: char 8 int 32 long 32 void * 32 off_t 64 ecs_char 8

$ aps libncurses5-dev | grep -i version
Version: 5.7+20090803-2ubuntu1

comment:5 Changed 10 years ago by andrew_b

  • Component changed from mc-core to mc-tty

comment:6 Changed 8 years ago by andrew_b

  • Branch state set to no branch
  • Milestone changed from 4.7 to Future Releases

comment:7 Changed 22 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to worksforme
  • Milestone Future Releases deleted

Unreproducible for me.
mc-4.8.20
ncurses-5.9
Various terminals: xterm-320, rxvt-unicode-9.20, mate-terminal-1.12.1.

Note: See TracTickets for help on using tickets.