Ticket #391 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

history is broken

Reported by: a.panov Owned by: slavazanko
Priority: major Milestone: 4.7.0-pre1
Component: mc-config-ini Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset: merged-master

Description

Reading/writing to ~/.mc/history is broken. Mc does not read it for (un)selection mask, in replace of mcedit and in many other cases. It does not save to history file at all. Moreover it reads some elements of "Quick cd" (Alt+c) partially, for example the element of 47=/usr/share/fonts/ under [input] section is loaded as
"/usr/share/fo".

It occures after ~June 1.

Change History

comment:1 Changed 10 years ago by andrew_b

  • Blocking 394 added

comment:1 Changed 10 years ago by slavazanko

  • Keywords review added
  • Status changed from new to accepted
  • Blocking 394 removed
  • Owner set to slavazanko

created branch 291_broken_history (parent: master)

Initial commit: changeset: 8a3e1a8f5ba05cd5873903ec90ec81a1cf90f338

comment:2 Changed 10 years ago by slavazanko

  • Blocking 394 added

comment:3 Changed 10 years ago by andrew_b

  • Keywords vote-andrew_b added

comment:4 Changed 10 years ago by angel_il

  • Keywords vote-angel_il added

comment:5 Changed 10 years ago by slavazanko

  • Status changed from accepted to testing
  • Keywords commited-master added; review vote-andrew_b vote-angel_il removed
  • Resolution set to fixed
  • Blocking 394 removed

comment:6 Changed 10 years ago by slavazanko

  • Status changed from testing to closed

comment:7 follow-up: ↓ 8 Changed 10 years ago by a.panov

  • Status changed from closed to reopened
  • Resolution fixed deleted

The issue with "/usr/share/fo" still remains. I reads "history" saved mc 4.6.1 with errors.

comment:8 in reply to: ↑ 7 ; follow-up: ↓ 9 Changed 10 years ago by andrew_b

Replying to a.panov:

The issue with "/usr/share/fo" still remains. I reads "history" saved mc 4.6.1 with errors.

Could you attach your history file to reproduce this bug?

comment:9 in reply to: ↑ 8 Changed 10 years ago by andrew_b

  • Status changed from reopened to closed
  • Resolution set to worksforme

Replying to andrew_b:

Could you attach your history file to reproduce this bug?

No answer...

comment:10 follow-up: ↓ 11 Changed 10 years ago by a.panov

  • Status changed from closed to reopened
  • Resolution worksforme deleted

History file was sent by private mail.

comment:11 in reply to: ↑ 10 ; follow-up: ↓ 12 Changed 10 years ago by andrew_b

  • Owner changed from slavazanko to andrew_b
  • Status changed from reopened to assigned
  • Keywords review added; commited-master removed
  • Milestone changed from 4.7 to 4.7.0-pre1

Please check 394_history_file branch.

comment:12 in reply to: ↑ 11 Changed 10 years ago by andrew_b

  • Status changed from assigned to testing
  • Resolution set to fixed

Replying to andrew_b:

Please check 394_history_file branch.

394_history_file branch has been merged to master.

Initial changeset:5a67008194a16d3dde24e385d7ab0a6adaf6bf69
Final changeset:b72e83193ad43526b0a6fd34dd4b3f407656b196

git log --pretty=oneline d5f1442..b72e831

comment:13 Changed 10 years ago by andrew_b

  • Status changed from testing to closed

comment:14 Changed 10 years ago by andrew_b

  • Keywords review removed
  • Component changed from mc-core to mc-config-ini
  • Status changed from closed to reopened
  • Resolution fixed deleted
  • severity set to no branch

Since glib requires that configs must be in UTF-8 codeset, we must convert history items to UTF-8 before saving and from UT8-8 after reading.

comment:15 Changed 10 years ago by slavazanko

  • Status changed from reopened to accepted
  • Owner changed from andrew_b to slavazanko
  • severity changed from no branch to on rework

Branch 391_history_is_broken created. Now in rework stage.

comment:16 Changed 10 years ago by slavazanko

  • severity changed from on rework to on review

comment:17 Changed 10 years ago by andrew_b

  • Votes for changeset set to andrew_b

comment:18 Changed 10 years ago by angel_il

  • Votes for changeset changed from andrew_b to andrew_b angel_il

comment:19 Changed 10 years ago by angel_il

  • severity changed from on review to approved

comment:20 Changed 10 years ago by slavazanko

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b angel_il to merged-master
  • Resolution set to fixed
  • severity changed from approved to merged

comment:21 Changed 10 years ago by slavazanko

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.