Ticket #392 (closed enhancement: duplicate)

Opened 10 years ago

Last modified 8 years ago

add "ignore further errors" tick for error dialog

Reported by: slyfox Owned by:
Priority: major Milestone: 4.8
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

Sometimes users perform operations with tons of files, like copying to FTP or some buggy fuse filesystem. On each operation error message popups. It annoys users when they have to press enter on each single file.

It would be great to add tick 'ignore further errors' in copy/move/etc. error dialog.

Realworld example:

$ cat /etc/fstab|grep curl
curlftpfs#ftp.gmss.ru /mnt/gmss fuse user,disable_eprt,iocharset=utf8,codepage=cp1251 0 0

Users report this FTP spits error on each file upload (during file close). It's likely FTP server or fuse related stuff, but there are many similar cases when user would like to just ignore occuring errors:

  • FTP servers without CHMOD command (i'm aware of 'preserve attributes' tick), filesystems with int sys_chmod(...) { return -ENOTIMPLEMENTED; }
  • filesystems with more constrained file naming (copying 'ext' dirs with symlinks and special symbols to 'vfat/ntfs' partitions)
  • other cases

Change History

comment:1 follow-up: ↓ 2 Changed 8 years ago by kdave

  • severity set to no branch

comment:2 in reply to: ↑ 1 Changed 8 years ago by kdave

Replying to kdave:

http://mail.gnome.org/archives/mc-devel/2003-June/msg00011.html

that was the patch adding an 'Ignore...' buttons

comment:3 Changed 8 years ago by kdave

http://mail.gnome.org/archives/mc-devel/2003-June/msg00010.html

and a strange error I encountered, dunno if it's still present but it'd be good to verify.

comment:4 Changed 8 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone changed from 4.7 to 4.8

Duplicate of #71.

Note: See TracTickets for help on using tickets.