Ticket #3613 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

FISH: I see non-existent dirs and files on the remote server

Reported by: gonzo_s Owned by:
Priority: major Milestone: 4.8.17
Component: mc-vfs Version: 4.8.16
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

What version of Midnight Commander is used?

GNU Midnight Commander 4.8.16
Built with GLib 2.32.4
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, fish
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

What steps will reproduce the problem?

Press F9;
Choose Left or Right;
Choose 'Shell link...';
Enter your credentials for a remote server;
Browse dirs there

What is the expected output?

Normal dirs/files names

What do you see instead?

Additional non-existent dirs and files with names like '23232336474504' etc.

Can someone confirm this?

Thank you.

Change History

comment:1 Changed 4 years ago by gonzo_s

With 4.8.15 version I don't see such behaviour. Everything is OK.

comment:2 in reply to: ↑ description ; follow-up: ↓ 3 Changed 4 years ago by andrew_b

Replying to gonzo_s:

Can someone confirm this?

I can. The bad commit is [ee6dd89deb5bbe28e60d5d7634d4c84b3cdd947e] (#3599).
Unfortunately, patch in #3611 doesn't fix this bug.

comment:3 in reply to: ↑ 2 Changed 4 years ago by andrew_b

Replying to andrew_b:

Unfortunately, patch in #3611 doesn't fix this bug.

Oops, sorry. It does.

comment:4 Changed 4 years ago by andrew_b

  • Blocked By 3611 added

comment:5 Changed 4 years ago by andrew_b

  • Milestone changed from Future Releases to 4.8.17

comment:6 Changed 4 years ago by gonzo_s

Ok, thank you. Gonna try it out.

comment:7 Changed 4 years ago by gonzo_s

Yes patch in #3611 fixes the problem! Thank you.

For anyone who desires to fix this on the fly: simply apply the patch to your /usr/lib/mc/fish/ls
You can take it from the release, patch it and replace the file if you like.

comment:8 Changed 4 years ago by zaytsev

  • Status changed from new to closed
  • Resolution set to duplicate
  • Blocked By 3611 removed

Closed as duplicate of #3611.

Note: See TracTickets for help on using tickets.