Ticket #3612 (closed defect: worksforme)

Opened 7 years ago

Last modified 7 years ago

fish on large files number

Reported by: gregoryfenton Owned by:
Priority: minor Milestone:
Component: mc-vfs Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

What version of Midnight Commander is used?
$ mc -V
GNU Midnight Commander 4.8.13
Built with GLib 2.43.1
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, sftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

What steps will reproduce the problem?

Transfer a file larger than 4 gigabytes
What is the expected output?
fish: storing file: x/y
What do you see instead?
fish: storing file: -z/y
Where x is current position of transfer, y is file size, z is 32 bit signed version of position

The issue is that the first parameter (z) is displayed in 32 bit signed and it should ideally be 64 bit unsigned, or at the very least the same as (y)

Change History

comment:1 Changed 7 years ago by andrew_b

  • Version changed from version not selected to master
  • Component changed from mc-core to mc-vfs

comment:2 Changed 7 years ago by and

Mhh,
not reproducible with mc 4.8.16 (copy 5GB file local -> remote fish shell)

comment:3 Changed 7 years ago by zaytsev

  • Status changed from new to closed
  • Resolution set to worksforme
  • Milestone Future Releases deleted

This was fixed long ago [2476f281dec2a88a46a9563c29ff1187be232379] which went into 4.8.7, it's not possible that this is happening on 4.8.13.

Note: See TracTickets for help on using tickets.