Ticket #4121 (closed defect: invalid)

Opened 14 months ago

Last modified 14 months ago

mc fails to delete any file from some zip archives

Reported by: unxed Owned by:
Priority: major Milestone:
Component: mc-vfs Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Samples attached.

Attachments

23-10-2012-b-fasi-eaep_greek.zip (181.8 KB) - added by unxed 14 months ago.
csv.zip (259 bytes) - added by unxed 14 months ago.
n2_cant_delete.zip (196 bytes) - added by unxed 14 months ago.
new.zip (192 bytes) - added by unxed 14 months ago.
new2.zip (204 bytes) - added by unxed 14 months ago.
win10test_greek.zip (146 bytes) - added by unxed 14 months ago.
windows_cyrillic.zip (330 bytes) - added by unxed 14 months ago.
winzip.zip (354 bytes) - added by unxed 14 months ago.
тест.zip (192 bytes) - added by unxed 14 months ago.

Change History

Changed 14 months ago by unxed

Changed 14 months ago by unxed

Changed 14 months ago by unxed

Changed 14 months ago by unxed

Changed 14 months ago by unxed

Changed 14 months ago by unxed

Changed 14 months ago by unxed

Changed 14 months ago by unxed

Changed 14 months ago by unxed

comment:1 Changed 14 months ago by unxed

This is probably due to incorrect processing of filename charset, see https://github.com/mate-desktop/engrampa/issues/5#issuecomment-703246764

comment:2 Changed 14 months ago by andrew_b

Ticket #4123 has been marked as a duplicate of this ticket.

comment:3 Changed 14 months ago by andrew_b

Ticket #4122 has been marked as a duplicate of this ticket.

comment:4 Changed 14 months ago by andrew_b

  • Component changed from mc-core to mc-vfs

comment:5 Changed 14 months ago by zaytsev-work

  • Status changed from new to closed
  • Resolution set to invalid
  • Milestone Future Releases deleted

mc doesn't do any zip unpacking itself. It uses other unpackers, like {{unzip}}, {{7z}}, etc. Once the bugfix is upstreamed there, it will start working in mc as well.

Version 0, edited 14 months ago by zaytsev-work (next)
Note: See TracTickets for help on using tickets.