Ticket #4123 (closed defect: duplicate)

Opened 14 months ago

Last modified 14 months ago

mc porcesses file names inside some zip archives incorrectly

Reported by: unxed Owned by:
Priority: major Milestone:
Component: mc-vfs Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

This zip file is extracted by mc to "╨Э╨╛╨▓╨░╤П\ ╤Д╨╛╤А╨╝╨░.csv"
But it should be extracted to "Новая форма.csv" as 7za shows:

$ 7za l csv.zip

7-Zip (a) [64] 16.02 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-21
p7zip Version 16.02 (locale=ru_RU.UTF-8,Utf16=on,HugeFiles?=on,64 bits,4 CPUs AMD A10-4600M APU with Radeon(tm) HD Graphics

(610F01),ASM,AES-NI)

Scanning the drive for archives:
1 file, 259 bytes (1 KiB)

Listing archive: csv.zip

--
Path = csv.zip
Type = zip
Physical Size = 259

Date Time Attr Size Compressed Name


2020-10-03 08:43:52 ..... 102 95 Новая форма.csv


2020-10-03 08:43:52 102 95 1 files

Attachments

csv.zip (259 bytes) - added by unxed 14 months ago.

Change History

Changed 14 months ago by unxed

comment:1 Changed 14 months ago by unxed

This is probably due to incorrect processing of filename charset, see https://github.com/mate-desktop/engrampa/issues/5#issuecomment-703246764

comment:2 Changed 14 months ago by andrew_b

  • Status changed from new to closed
  • Component changed from mc-core to mc-vfs
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #4121.

Note: See TracTickets for help on using tickets.