Ticket #370 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

case-insensitive search broken in editor

Reported by: ossi Owned by: slavazanko
Priority: major Milestone: 4.7
Component: mc-core Version: master
Keywords: Cc: yury@…
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

the "case sensitive" checkbox in the editor's find dialog has no effect - the search is always case sensitive.

Change History

comment:1 Changed 10 years ago by andrew_b

Very strange. Work fine for me. Tested in Latin and Russian text files in ASCII, KOI8-R, CP1251 and UTF-8 codesets.

comment:2 Changed 10 years ago by ossi

it might have something to do with configure telling me "charset support: no" (even though it does find iconv). in that context i also find it a bit weird that the checkbox is present at all, given the announced lack of support.
fwiw, i was searching for plain ascii chars only.

comment:3 Changed 10 years ago by ZYV

  • Cc yury@… added

I can confirm this on the latest git master.

...
checking for iconv... yes
checking for iconv declaration... 
         extern size_t iconv (iconv_t cd, char * *inbuf, size_t *inbytesleft, char * *outbuf, size_t *outbytesleft);
checking for nl_langinfo and CODESET... yes
...

Configuration:

  Source code location:       .
  Compiler:                   gcc -std=gnu99
  Compiler flags:             -g -O2 -Wall
  File system:                Midnight Commander Virtual File System
                              cpio, tar, ftp, fish, extfs, sfs
  Screen library:             S-Lang library (installed on the system)
  Mouse support:              gpm and xterm
  X11 events support:         yes
  With subshell support:      yes
  Internal editor:            yes
  Support for charset:        no

comment:4 follow-up: ↓ 5 Changed 10 years ago by ZYV

./configure --enable-charset fixes the issue for me. Still IMO, this needs to be fixed. No charset -> no checkbox and --enable-charset should be on by default.

comment:5 in reply to: ↑ 4 Changed 10 years ago by andrew_b

Replying to ZYV:

./configure --enable-charset fixes the issue for me. Still IMO, this needs to be fixed.

Agree. It' a bug.

No charset -> no checkbox

I believe, you mean the "All charsets" checkbox. The "Case sensitive" checkbox should not be depend upon --enable-charset option.

comment:6 Changed 10 years ago by slavazanko

  • Status changed from new to accepted
  • Owner set to slavazanko
  • Keywords review added

Branch 370_ci_search created (parent branch: master).
Initial changest - changeset:7e29613ba90873c66e9b39b541e1490e1db2035b

Please, review, test and vote.

comment:7 Changed 10 years ago by slavazanko

I believe, you mean the "All charsets" checkbox.

This checkbox now related to --[enable|disable]-charset configure option.
Second patch to 370_ci_search branch: changeset:52c6e5a33b9ad09805e8dca43cafd392d0c00d63

comment:8 Changed 10 years ago by andrew_b

  • Keywords vote-andrew_b added

OK. The bug described in this ticket is fixed. My vote here.

comment:9 Changed 10 years ago by styx

  • Keywords vote-styx approved added; review removed

comment:10 Changed 10 years ago by slavazanko

  • Status changed from accepted to testing
  • Keywords commited-master added; vote-andrew_b vote-styx approved removed
  • Resolution set to fixed

comment:11 Changed 10 years ago by slavazanko

  • Status changed from testing to closed

comment:12 follow-up: ↓ 13 Changed 10 years ago by slavazanko

Sorry, previous changeset specified twice.
changeset:17343149d60c291281dcdaa182a864fbec6dd432

comment:13 in reply to: ↑ 12 Changed 10 years ago by andrew_b

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Component changed from mcedit to mc-core
  • Keywords rework added; commited-master removed

Replying to slavazanko:

changeset:17343149d60c291281dcdaa182a864fbec6dd432

This changeset not totally fixes the usage of 'All charsets' related widgets.

Ticket reopend due to #387.

comment:14 Changed 10 years ago by andrew_b

  • Status changed from reopened to closed
  • Keywords rework removed
  • Resolution set to fixed

Since bug described in this ticket have been fixed, ticket is closed.
See http://www.midnight-commander.org/ticket/387#comment:2 and following comments.

Note: See TracTickets for help on using tickets.