Ticket #369 (closed defect: invalid)

Opened 10 years ago

Last modified 9 years ago

line drawing characters are messed up in linux console

Reported by: ossi Owned by: ZYV
Priority: major Milestone: 4.7
Component: mc-core Version: master
Keywords: Cc: yury@…
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

practically all line drawing characters are messed up in a linux console for me. it works in an xterm and konsole, though - even though the setup is in theory the same (all latin1).
not a slang vs. ncurses issue this time. :)
worked before, of course. :)

Change History

comment:1 Changed 10 years ago by ZYV

  • Cc yury@… added

I can't reproduce this one.

zyv@mypride:~/Desktop$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME=en_GB.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=en_GB.UTF-8
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT=en_GB.UTF-8
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

┌────────── Display bits ───────────┐
│                                   │
│ (*) UTF-8 output                  │
│ ( ) Full 8 bits output            │
│ ( ) ISO 8859-1                    │
│ ( ) 7 bits                        │
│                       [ Cancel ]  │
│ [x] Full 8 bits input [< OK >]    │
│                                   │
└───────────────────────────────────┘

./configure:
...
  Screen library:             S-Lang library (installed on the system)
...

comment:2 follow-up: ↓ 3 Changed 10 years ago by ossi

my locale is all POSIX (i.e., unset). it does not matter whether i set it to utf-8 or "full 8 bits" (and it refuses to keep iso 8859-1 which would be correct, but that's documented in another report). and note that this does work in the terminal emulators despite identical environment settings. setting TERM=xterm in the linux console doesn't change a thing. setting TERM=linux in an xterm makes a mess, but it looks differently than the one in the console.

comment:3 in reply to: ↑ 2 Changed 10 years ago by andrew_b

Replying to ossi:
it looks differently than the one in the console.

In console: is that mess is different from time to time or it constant?

comment:4 Changed 10 years ago by ossi

constant. it is "simply" a wrong encoding.

bleh, this seems to be some kind of linux problem which appeared fairly recently, in fact - umlauts are messed up even if i don't fire up mc. sorry for the noise. please close as invalid (why can't i do that?).

comment:5 Changed 10 years ago by ZYV

  • Status changed from new to assigned
  • Owner set to ZYV

OK. I think that's because the ticket should be assigned before it's closed.

comment:6 Changed 10 years ago by ZYV

  • Status changed from assigned to testing
  • Resolution set to invalid

comment:7 Changed 10 years ago by slavazanko

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.