Ticket #3563 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

"Directory hotlist" dialog should use WListbox's change notification.

Reported by: mooffie Owned by:
Priority: minor Milestone: 4.8.16
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking: #3569
Branch state: merged Votes for changeset: committed-master

Description

The directory hotlist updates the "Directory path" label when the item in the listbox changes.

It uses MSG_POST_KEY to detect this change.

We should instead use WListbox's notification mechanism: it sends a MSG_ACTION in such case.

The patch fixes this.

Advantage:

The dialog will be able to detect changes caused by mouse clicks too. Currently it can't.

Change History

comment:1 Changed 4 years ago by mooffie

Note that after tending to ticket:3566 the code will be tidier:

case MSG_INIT:
case MSG_NOTIFY:
    uupdate_path_name (); 
    return MSG_HANDLED;

comment:2 Changed 4 years ago by andrew_b

  • Blocking 3569 added

comment:3 Changed 4 years ago by andrew_b

  • Status changed from new to closed
  • Votes for changeset set to committed-master
  • Resolution set to fixed
  • Branch state changed from no branch to merged
  • Milestone changed from Future Releases to 4.8.16
Note: See TracTickets for help on using tickets.