Ticket #3562 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Mouse clicking in listbox doesn't notify dialog of change

Reported by: mooffie Owned by:
Priority: minor Milestone: 4.8.16
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking: #3569
Branch state: merged Votes for changeset: committed-master

Description

The listbox widget has a useful feature: it sends MSG_ACTION to the dialog to notify it when the selected item changes. This makes it easy to implement the common UI pattern in which widgets update themselves in response to listbox change.

This UI pattern is used in the following dialogs:

  • Directory hotlist / Active VFS directories
  • External Panelize
  • Slava's "friendly bookmark manager" (screenshot at ticket:2979)
  • (A few scripts shipped with mc2)

However, this MSG_ACTION isn't fired for changes caused by mouse clicking. Only for those caused by the keyboard.

This patch fixes this.

Attachments

3562-listbox-should-fire-MSG_ACTION-on-mouse-clicks-too.patch (4.2 KB) - added by mooffie 4 years ago.

Change History

comment:1 Changed 4 years ago by andrew_b

  • Blocking 3569 added

comment:2 Changed 4 years ago by andrew_b

  • Status changed from new to closed
  • Votes for changeset set to committed-master
  • Resolution set to fixed
  • Branch state changed from no branch to merged
  • Milestone changed from Future Releases to 4.8.16
Note: See TracTickets for help on using tickets.