Ticket #3370 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Lower [hardlink]'s precedence

Reported by: mooffie Owned by:
Priority: trivial Milestone:
Component: mc-config-ini Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

On my system I noticed that sometimes files (pictures, vids) aren't colored according to their types:

http://tinypic.com/view.php?pic=30k9atw&s=8

...as seen here, some 'png' files and one 'flv' aren't colored. It turns out that these files have 2 or more links pointing to them (see the "nlink" column in the screenshot). I don't know why these files have 2 links. It happens to be an NTFS partition. Maybe it's not uncommon there to find such things.

Now, look at filehighlight.ini:

https://github.com/MidnightCommander/mc/blob/master/misc/filehighlight.ini

"[hardlink]" comes before "[graph]", which is why (I think) it gets precedence.

So I think we should move the [hardlink] section to the bottom of the file. Why? It demands too much cognitive effort of the user to have colors serve two different purposes (indicating either filesystem-type or application-type). Unless hardlinks are shown in *very* distinctive colors (something no default skin does), common users won't "get" them.

Change History

comment:1 Changed 5 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate

Closed as duplicate of #3234.
Please use search before create tickets.

comment:2 Changed 5 years ago by andrew_b

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.