Ticket #2319 (closed defect: invalid)

Opened 9 years ago

Last modified 9 years ago

crash in replace when the first occurence is skipped

Reported by: ply Owned by:
Priority: major Milestone:
Component: mcedit Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

The problem is at editcmd.c:1869 where the search_start pointer is adjusted. The problem is that the referred repl_str variable is only assigned for actual replaces, and even during subsequent skips it only points to the last replaced occurence. So its usage when adjusting the search_start pointer is weird. I think a simple search_start++ would do just fine.

Change History

comment:1 Changed 9 years ago by andrew_b

  • Status changed from new to closed
  • Version 4.7.3 deleted
  • Resolution set to invalid
  • Milestone 4.7 deleted

Please use search before create new ticket.

Fixed in #2272.

Note: See TracTickets for help on using tickets.