Ticket #2272 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

mcedit: replace confirmation - segfault on Skip/Cancel

Reported by: lly Owned by: andrew_b
Priority: major Milestone: 4.7.4
Component: mcedit Version: 4.7.3
Keywords: Cc: zaytsev
Blocked By: Blocking:
Branch state: Votes for changeset: committed-master committed-stable

Description

Step to reproduce:

1) Edit some file
2) press F4 (replace) - fill some search/replacement string, seacrh type - "Normal",
3) when mcedit ask "Confirm replace" answer Skip or Cancel
4) got Segmentation fault

gdb backtrace attached, produced under OpenSUSE 11.1 x86_64

Attachments

backtrace.txt (1.6 KB) - added by lly 9 years ago.
gdb backtrace

Change History

Changed 9 years ago by lly

gdb backtrace

comment:1 Changed 9 years ago by zaytsev

  • Cc zaytsev added
  • Keywords stable-candidate added

Tadam! Editor segfaults on both master & stable.

comment:2 Changed 9 years ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted
  • severity changed from no branch to on review
  • Summary changed from mcedit: search/replace - segfault on Skip/Cancel to mcedit: replace confirmation - segfault on Skip/Cancel

Created 2272_editor_replace_skip_cancel_segfault branch. Parent branch is master.
changeset:4e9912e65bba037c047cb0c7de266083a2871979

comment:3 Changed 9 years ago by andrew_b

  • Milestone changed from 4.7 to 4.7.4

comment:4 Changed 9 years ago by lly

  • Votes for changeset set to lly

Changeset fixes problem for me, thanks.

comment:5 Changed 9 years ago by zaytsev

Did you actually audit the code? This is the purpose of the votes field. I am not voting, because although it fixes the issue for me, I am not competent enough to review the patch.

comment:6 Changed 9 years ago by lly

  • Votes for changeset lly deleted

Sorry, I don't do audit the code. I just build branch, look that no new errors/warnings, and perform tests.

From wiki WorkingGuideLines I apologize that votes field meas that patch is "fine" for me.

comment:7 Changed 9 years ago by angel_il

  • Votes for changeset set to angel_il

comment:8 Changed 9 years ago by slavazanko

  • Votes for changeset changed from angel_il to angel_il slavazanko

comment:9 Changed 9 years ago by andrew_b

  • severity changed from on review to approved

comment:10 Changed 9 years ago by andrew_b

  • Keywords stable-candidate removed
  • Status changed from accepted to testing
  • Votes for changeset changed from angel_il slavazanko to committed-master committed-stable
  • Resolution set to fixed
  • severity changed from approved to merged

comment:11 Changed 9 years ago by andrew_b

  • Status changed from testing to closed

Sorry...

Cherry-picked to 4.7.0-stable.
changeset:65941b38c5ea855ff2a791867920626e48769a61

Note: See TracTickets for help on using tickets.