Ticket #3913 (closed enhancement: fixed)

Opened 5 months ago

Last modified 5 months ago

Safe overwrite

Reported by: duke Owned by: andrew_b
Priority: major Milestone: 4.8.21
Component: mc-core Version: master
Keywords: safe overwrite Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

With overwrite the problem is the same like at delete (e.g. below). "Safe delete" is a very good feature (default choice is the "No" at deletes) but could activate the "safe overwrite" mode as well, or could be a separated switch for "safe overwrite".

e.g.: I sort my files between left and right panels with Move. On the destination panel there could be files with the same name. In this case every time I press Enter for open the file, and F6 for move it. Enter again for open the file, and F6 to move, but when the file exists, the fast Enter will immediately overwrite the file (because overwrite prompted with Yes by default).

Change History

comment:1 Changed 5 months ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted
  • Milestone changed from Future Releases to 4.8.21

comment:2 Changed 5 months ago by andrew_b

  • Branch state changed from no branch to on review

Branch: 3913_safe_overwrite
Initial changeset:34712ec05b66b7bde2c10357ffd9145231a330a1

comment:3 Changed 5 months ago by andrew_b

  • Votes for changeset set to andrew_b
  • Branch state changed from on review to approved

comment:4 Changed 5 months ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

Merged to master: [35d21b6ea26886bfa990efb1ae21b78adc180a7c].

git log --pretty=oneline a66ee73..35d21b6

comment:5 Changed 5 months ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.