Ticket #49 (closed defect: wontfix)

Opened 11 years ago

Last modified 6 years ago

savannah: Reassigned item: putty and other terminals

Reported by: mirkobau Owned by:
Priority: major Milestone:
Component: mc-core Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description (last modified by ossi) (diff)

Original: http://savannah.gnu.org/bugs/?16910

Submitted by:mirko <mirkobau>Submitted on:Thu 22 Jun 2006 01:30:35 PM UTC
Category:NoneSeverity:3 - Normal
Status:NonePrivacy:Public
Assigned to:NoneOpen/Closed:Open
Release:NoneOperating System:None

Original submission:

putty (puttyssh.org) is an xterm-compliant terminal emulator with 
mouse support, and has its own terminfo definition file that 
instructs ncurses how to correctly recognize the keys received, but 
in 'src/main.c' the 'if..' block does tests only on xterm, rxvt, 
and dtterm terminals.

i used TERM=xterm-color, but when i found the terminfo file 'putty-
256color' i wanted to use it.
After standard compilation everythyng was running well (home/end 
keys, and all others), but mc had no mouse support.

actually i have corrected this problem adding the comparison:

|| strncmp (termvalue, "putty", 5) == 0

in the main.c file, in function init_xterm_support(), but i suggest 
to insert a parameter in a global option file, in wich a sysadmin 
could insert a line such as:

[xterm-compliant]
xterm*
rxvt*
dtterm
putty*
fooxterm*
barxterm*
...

and so on.
thank you for the time spent in reading my opinions.

bye from Mir (it@euro).

Comment 1 by Pavel Tsekov <ptsekov> at Tue 25 Apr 2006 01:44:34 PM UTC:

http://puttyssh.org/faq.html#faq-term

Where does putty-256color come from ?

Anyway, I think that your suggestion about adding a new section to 
the configuration file makes sense.

Comment 2 by mirko <mirkobau> at Tue 25 Apr 2006 02:56:11 PM UTC:

i took it from a terminfo definitions file, downloadable from:

ftp://invisible-island.net/ncurses/

the file i used is: terminfo.src.gz

inside it i have found a section with putty and putty-256color 
definitions:

gunzip terminfo.src.gz
tic terminfo.src

note: tic says that terminfo.src has some errors, but i didn't 
care, 'cause i really need the definitions for xterm* and putty* 
terminals.

Comment 3 by Leonard den Ottolander <leonardjo> at Thu 22 Jun 2006 01:30:35 PM UTC:

This item has been reassigned from the project GNU Midnight 
Commander patch tracker to your tracker.

The original report is still available at patch #5050

Following are the information included in the original report:

[field #0] Item ID: 5050
[field #1] Group ID: 3521
[field #2] Open/Closed: Open
[field #3] Severity: 3 - Normal
[field #4] Privacy: Public
[field #6] Category: Keyboard input
[field #7] Submitted by: mirkobau
[field #8] Assigned to: None
[field #9] Submitted on: Monday 24/04/06 at 11:34
[field #10] Summary: putty and other terminals
[field #11] Original Submission: putty (puttyssh.org) is an xterm-
compliant terminal emulator with mouse support, and has its own 
terminfo definition file that instructs ncurses how to correctly 
recognize the keys received, but in src/main.c the if.. block does 
tests only on xterm, rxvt, and dtterm terminals.

i used TERM=xterm-color, but when i found the terminfo file putty-
256color i wanted to use it.
After standard compilation everythyng was running well (home/end 
keys, and all others), but mc had no mouse support.

actually i have corrected this problem adding the comparison:

| | strncmp (termvalue, "putty", 5) == 0

in the main.c file, in function init_xterm_support(), but i suggest 
to insert a parameter in a global option file, in wich a sysadmin 
could insert a line such as:

[xterm-compliant]
xterm*
rxvt*
dtterm
putty*
fooxterm*
barxterm*
...

and so on.
thank you for the time spent in reading my opinions.

bye from Mir (it@euro).
[field #13] Item Group: None
[field #14] Status: None
[field #15] Component Version: None
[field #16] Operating System: None
[field #17] Reproducibility: None
[field #18] Size (loc): None
[field #19] Fixed Release: None
[field #20] Planned Release: None
[field #21] Effort: 0.00
[field #25] Priority: 5 - Normal
[field #28] Percent Complete: 0%
[field #30] Release: None
[field #55] Custom Select Box #1: None
[field #56] Custom Select Box #2: None
[field #57] Custom Select Box #3: None
[field #58] Custom Select Box #4: None
[field #59] Custom Select Box #5: None
[field #60] Custom Select Box #6: None
[field #61] Custom Select Box #7: None
[field #62] Custom Select Box #8: None
[field #63] Custom Select Box #9: None
[field #64] Custom Select Box #10: None

Change History

comment:1 Changed 11 years ago by slavazanko

I can't attach related file from Savannah because limit (256kb)

Direct link to file: http://savannah.gnu.org/bugs/download.php?file_id=9834

comment:2 Changed 10 years ago by styx

  • Milestone set to future releases

comment:3 Changed 10 years ago by angel_il

  • Status changed from new to closed
  • Resolution set to invalid
  • severity set to no branch

use TERM=xterm for this

comment:4 Changed 10 years ago by angel_il

  • Status changed from closed to reopened
  • Resolution invalid deleted

comment:5 Changed 10 years ago by angel_il

  • Status changed from reopened to closed
  • Resolution set to wontfix

comment:6 Changed 10 years ago by slavazanko

  • Milestone future releases deleted

comment:7 Changed 6 years ago by ossi

  • Description modified (diff)
  • Branch state set to no branch
  • Reporter changed from slavazanko to mirkobau
Note: See TracTickets for help on using tickets.