Ticket #414 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

Regression: shell patterns in copy dialog do not work

Reported by: vda Owned by: slavazanko
Priority: major Milestone: 4.7.0-pre2
Component: mc-core Version: 4.6.2
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset: committed-master

Description (last modified by angel_il) (diff)

I have two directories selected:
busybox.2 and busybox.t2

I press F5 and ask mc to copy *2 to *3:

┌─────────────────────────── Copy ───────────────────────────┐
│ Copy 2 directories with source mask:                       │
│ *2                                                     [ ] │
│                                   [x] Using shell patterns │
│ to:                                                        │
│ *3                                                     [ ] │
│ [ ] follow Links            [ ] Dive into subdir if exists │
│ [x] preserve Attributes                [ ] Stable Symlinks │
│           [< OK >]   [ Background ]   [ Cancel ]           │
└────────────────────────────────────────────────────────────┘

It creates directory named "*3", copies busybox.2 to it, then tries to copy busybox.t2 to it and complains when it sees existing files.

Looks like despite "[x] Using shell patterns" option being selected, it does not handle it right.

mc-2.6.1 worked as expected in this situation: it was creating copies named busybox.3 and busybox.t3

Attachments

8.patch (1.2 KB) - added by vda 10 years ago.
Updated fix

Change History

comment:1 Changed 10 years ago by slavazanko

Try to use next test case:

source mask: *2
to: \13

chars '*' and '?' mean implicit replacement groups. For example,

File abscdefgh

source mask: ???*
to: \1 \2 \4 - \3

Result: a b defgh - c

}}

I think, in your test case usage of asterisk in 'to:' field not intuitive...

comment:2 Changed 10 years ago by slavazanko

I think, behavior with asterisk in 'to:' field is deprecated (like as scanf search type).

Is this ticket actual?

comment:3 follow-up: ↓ 4 Changed 10 years ago by vda

I think, in your test case usage of asterisk in 'to:' field not intuitive...

Press F5, then F1. It is still documented there in the help. And it was working in previous versions.

In programs like editors and mc, users tend to memorize things by keystrokes. Gratuitous changes in interface force people to relearn.

You were understandably pissed off by bad maintainership of old MC by Pavel. I was too. But if you want to fare better, pay attention to your user's needs. Don't make their experience with new versions of MC painful unless you have to.

Since I installed latest git, I have a number of things which work differently, or do not work at all:

File search dialog is no more at F9, right, right, down, down, enter. It is one point lower. Argh. I try to use M-? now.

_In_ file search dialog, travelling between filename field and search string field takes FOUR up/down arrows. In 2.6.1, it was taking just one. Also, search defaults have changed (regex was on by default in older version, for example).

In editor, F7 search does not remember last search string across editing sessions. As soon as one exits editor and enters it again, F7 will show empty string.

In editor, blue arrows and dots for whitespace appear to be non-configurable. How to turn it off? (A keyboard toggle would be ideal).

I will try to address each of these things with bug reports and hopefully even patches.

comment:4 in reply to: ↑ 3 Changed 10 years ago by slyfox

Replying to vda:

I think, in your test case usage of asterisk in 'to:' field not intuitive...

Press F5, then F1. It is still documented there in the help. And it was working in previous versions.

It's clearly an easily fixable regression (I find useful to copy file '*' to '*.back' time to time too). Will be fixed it this ticket.


In programs like editors and mc, users tend to memorize things by keystrokes. Gratuitous changes in interface force people to relearn.

You were understandably pissed off by bad maintainership of old MC by Pavel. I was too. But if you want to fare better, pay attention to your user's needs. Don't make their experience with new versions of MC painful unless you have to.

Since I installed latest git, I have a number of things which work differently, or do not work at all:

File search dialog is no more at F9, right, right, down, down, enter. It is one point lower. Argh. I try to use M-? now.

_In_ file search dialog, travelling between filename field and search string field takes FOUR up/down arrows. In 2.6.1, it was taking just one. Also, search defaults have changed (regex was on by default in older version, for example).

In editor, F7 search does not remember last search string across editing sessions. As soon as one exits editor and enters it again, F7 will show empty string.

In editor, blue arrows and dots for whitespace appear to be non-configurable. How to turn it off? (A keyboard toggle would be ideal).

I will try to address each of these things with bug reports and hopefully even patches.

Separate bugs would be ideal. Some of them might already present as tickets.

Thanks!

comment:5 Changed 10 years ago by angel_il

  • severity set to no branch
  • Description modified (diff)

Changed 10 years ago by vda

Updated fix

comment:6 Changed 10 years ago by slavazanko

  • Milestone changed from 4.7 to 4.7.0-pre3

comment:7 Changed 10 years ago by slavazanko

  • Status changed from new to accepted
  • Owner set to slavazanko
  • severity changed from no branch to on review
  • Milestone changed from 4.7.0-pre3 to 4.7.0-pre2

Created branch 414_shell_patterns_in_copy_dialog (parent: master)

Initial changeset:4586834cb9d4d84b4493bbb58e36d9c32abfb409

Review, please.

comment:8 Changed 10 years ago by slavazanko

  • Votes for changeset set to slavazanko

comment:9 Changed 10 years ago by angel_il

  • Votes for changeset changed from slavazanko to slavazanko angel_il
  • severity changed from on review to approved

comment:10 Changed 10 years ago by slavazanko

  • Status changed from accepted to testing
  • Votes for changeset changed from slavazanko angel_il to commited-master
  • Resolution set to fixed
  • severity changed from approved to merged

comment:11 Changed 10 years ago by slavazanko

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.