Ticket #4024 (closed defect: duplicate)

Opened 7 weeks ago

Last modified 7 weeks ago

4.8.23: core dumping

Reported by: kloczek Owned by:
Priority: major Milestone:
Component: mc-core Version: 4.8.23
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description (last modified by andrew_b) (diff)

$ coredumpctl gdb /usr/bin/mc
           PID: 4046675 (mc)
           UID: 1000 (tkloczko)
           GID: 1000 (tkloczko)
        Signal: 11 (SEGV)
     Timestamp: Sat 2019-10-05 23:38:51 BST (12min ago)
  Command Line: /usr/bin/mc -P /var/tmp/mc-tkloczko/mc.pwd.1088124
    Executable: /usr/bin/mc
 Control Group: /user.slice/user-1000.slice/session-62.scope
          Unit: session-62.scope
         Slice: user-1000.slice
       Session: 62
     Owner UID: 1000 (tkloczko)
       Boot ID: bb9bbf6eca594bdb914f10da6e8fca54
    Machine ID: ddd9adc076fd4480afcea67383c00b78
      Hostname: barrel
       Storage: /var/lib/systemd/coredump/core.mc.1000.bb9bbf6eca594bdb914f10da6e8fca54.4046675.1570315131000000000000.lz4
       Message: Process 4046675 (mc) of user 1000 dumped core.
                
                Stack trace of thread 4046675:
                #0  0x000056265eb3ebc8 vfs_stamp_compare (mc)
                #1  0x00007f52f1078ee1 g_slist_find_custom (libglib-2.0.so.0)
                #2  0x000056265eb3ed3c vfs_stamp (mc)
                #3  0x000056265eb99ccd extfs_get_path (mc)
                #4  0x000056265eb9a351 extfs_internal_stat (mc)
                #5  0x000056265eb7e5d4 mc_stat (mc)
                #6  0x000056265eb7e8cf cpio_super_check (mc)
                #7  0x000056265eb80707 vfs_get_super_by_vpath (mc)
                #8  0x000056265eb807a3 vfs_s_get_path (mc)
                #9  0x000056265eb808de vfs_s_inode_from_path (mc)
                #10 0x000056265eb80975 vfs_s_internal_stat (mc)
                #11 0x000056265eb7e5d4 mc_stat (mc)
                #12 0x000056265eb7e81d tar_super_check (mc)
                #13 0x000056265eb80707 vfs_get_super_by_vpath (mc)
                #14 0x000056265eb807a3 vfs_s_get_path (mc)
                #15 0x000056265eb80be1 vfs_s_getid (mc)
                #16 0x000056265eb7f9b1 vfs_stamp_create (mc)
                #17 0x000056265eb91cd4 extfs_close (mc)
                #18 0x000056265eb7a99c mc_close (mc)
                #19 0x000056265eb7aa17 cpio_free_archive (mc)
                #20 0x000056265eb7b34d vfs_s_free_super (mc)
                #21 0x000056265eb3eca6 vfs_expire (mc)
                #22 0x000056265eb66351 tty_get_event (mc)
                #23 0x000056265eb785f1 dlg_run (mc)
                #24 0x000056265ebbd71b mcview_viewer (mc)
                #25 0x000056265ebbfd3b view_file_at_line (mc)
                #26 0x000056265ebbff25 do_view_cmd (mc)
                #27 0x000056265ebc4fe8 midnight_execute_cmd (mc)
                #28 0x000056265eb62249 buttonbar_callback (mc)
                #29 0x000056265eb78308 dlg_process_event (mc)
                #30 0x000056265eb785fe dlg_run (mc)
                #31 0x000056265eb3d3f6 main (mc)
                #32 0x00007f52f14ad1a3 __libc_start_main (libc.so.6)
                #33 0x000056265eb3d97e _start (mc)

GNU gdb (GDB) Fedora 8.3.50.20190824-26.fc32
Copyright (C) 2019 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/bin/mc...
Reading symbols from /usr/lib/debug/usr/bin/mc-4.8.23-4.fc32.x86_64.debug...
[New LWP 4046675]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Core was generated by `/usr/bin/mc -P /var/tmp/mc-tkloczko/mc.pwd.1088124'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x000056265eb3ebc8 in vfs_stamp_compare (a=0x0, b=0x7ffefb8b3868) at gc.c:130
130	gc.c: No such file or directory.
Missing separate debuginfos, use: dnf debuginfo-install glib2-2.63.0-2.fc32.x86_64 glibc-2.30.9000-6.fc32.x86_64 gpm-libs-1.20.7-20.fc32.x86_64 libssh2-1.9.0-3.fc32.x86_64 nss-mdns-0.14.1-4.fc31.x86_64 openssl-libs-1.1.1d-2.fc32.x86_64 pcre-8.43-3.fc32.x86_64 slang-2.3.2-6.fc31.x86_64 sssd-client-2.2.0-6.fc32.x86_64 zlib-1.2.11-19.fc32.x86_64
(gdb) bt full
#0  0x000056265eb3ebc8 in vfs_stamp_compare (a=0x0, b=0x7ffefb8b3868) at gc.c:130
        vsa = 0x0
        vsb = 0x7ffefb8b3868
#1  0x00007f52f1078ee1 in g_slist_find_custom () from /lib64/libglib-2.0.so.0
No symbol table info available.
#2  0x000056265eb3ed3c in vfs_stamp (v=<optimized out>, id=<optimized out>) at gc.c:165
        what = {v = 0x56265ec14e20 <extfs_subclass>, id = 0x56265f54bd90, time = {tv_sec = 0, tv_usec = 0}}
        stamp = <optimized out>
        ret = 0
#3  0x000056265eb99ccd in extfs_get_path (vpath=0x56265f54e1a0, archive=0x7ffefb8b39a0, flags=<optimized out>) at extfs.c:699
        archive_name = 0x56265f5460d0 "/home/tkloczko/rpmbuild/SRPMS/ready/nano-4.5-2.fc32.src.rpm"
        result = -1
        parc = 0x56265f514a60 = {0x56265f54bd90}
        fstype = 16
        path_element = 0x56265f581030
        a = 0x56265f54bd90
#4  0x000056265eb9a351 in extfs_internal_stat (vpath=<optimized out>, buf=0x56265ec16260 <sb>, resolve=1) at extfs.c:1101
        archive = 0x56265f539230
        q = <optimized out>
        entry = <optimized out>
        result = -1
#5  0x000056265eb7e5d4 in mc_stat (vpath=0x56265f54e1a0, buf=0x56265ec16260 <sb>) at interface.c:573
        result = -1
        path_element = 0x56265f581030
#6  0x000056265eb7e8cf in cpio_super_check (vpath=<optimized out>) at cpio.c:818
        stat_result = <optimized out>
        sb = {st_dev = 0, st_ino = 20, st_nlink = 0, st_mode = 33060, st_uid = 0, st_gid = 0, __pad0 = 0, st_rdev = 0, st_size = 0, st_blksize = 512, st_blocks = 0, 
          st_atim = {tv_sec = 1570143600, tv_nsec = 0}, st_mtim = {tv_sec = 1570143600, tv_nsec = 0}, st_ctim = {tv_sec = 1570143600, tv_nsec = 0}, __glibc_reserved = {
            94722808062032, 1, 94722808062032}}
#7  0x000056265eb80707 in vfs_get_super_by_vpath (vpath=0x56265f54e180) at direntry.c:1120
        iter = <optimized out>
        cookie = 0x0
        path_element = 0x56265f546300
--Type <RET> for more, q to quit, c to continue without paging--
        subclass = 0x56265ec16060 <cpio_subclass>
        super = 0x0
        vpath_archive = 0x56265f54e1a0
#8  0x000056265eb807a3 in vfs_s_get_path (vpath=0x56265f54e180, archive=0x7ffefb8b3ab0, flags=0) at direntry.c:1173
        retval = 0x56265f5894c0 "nano-4.5.tar.xz"
        result = -1
        super = <optimized out>
        path_element = 0x56265f546300
        subclass = <optimized out>
#9  0x000056265eb808de in vfs_s_inode_from_path (vpath=0x56265f54e180, flags=1) at direntry.c:395
        super = 0x56265f57ff20
        ino = <optimized out>
        q = <optimized out>
        path_element = <optimized out>
#10 0x000056265eb80975 in vfs_s_internal_stat (vpath=<optimized out>, buf=0x56265ec19860 <stat_buf>, flag=<optimized out>) at direntry.c:508
        ino = <optimized out>
#11 0x000056265eb7e5d4 in mc_stat (vpath=0x56265f54e180, buf=0x56265ec19860 <stat_buf>) at interface.c:573
        result = -1
        path_element = 0x56265f546300
#12 0x000056265eb7e81d in tar_super_check (vpath=<optimized out>) at tar.c:920
        stat_result = <optimized out>
        stat_buf = {st_dev = 1, st_ino = 1, st_nlink = 1, st_mode = 33204, st_uid = 0, st_gid = 0, __pad0 = 808464432, st_rdev = 0, st_size = 1493816, 
          st_blksize = 3472337106047809073, st_blocks = 3472328296227680304, st_atim = {tv_sec = 1570206511, tv_nsec = 0}, st_mtim = {tv_sec = 1570206511, 
            tv_nsec = 0}, st_ctim = {tv_sec = 1570206511, tv_nsec = 0}, __glibc_reserved = {526002319969, 288230764183173117, 81346278045570790}}
#13 0x000056265eb80707 in vfs_get_super_by_vpath (vpath=0x56265f4ad930) at direntry.c:1120
        iter = <optimized out>
        cookie = 0x0
        path_element = 0x56265f54e2d0
        subclass = 0x56265ec19440 <tarfs_subclass>
        super = 0x0
        vpath_archive = 0x56265f54e180
#14 0x000056265eb807a3 in vfs_s_get_path (vpath=0x56265f4ad930, archive=0x7ffefb8b3bd0, flags=1) at direntry.c:1173
        retval = 0x56265f534790 "nano-4.5"
--Type <RET> for more, q to quit, c to continue without paging--
        result = -1
        super = <optimized out>
        path_element = 0x56265f54e2d0
        subclass = <optimized out>
#15 0x000056265eb80be1 in vfs_s_getid (vpath=<optimized out>) at direntry.c:834
        archive = 0x0
        p = <optimized out>
#16 0x000056265eb7f9b1 in vfs_stamp_create (vclass=0x56265ec14e20 <extfs_subclass>, id=0x56265f54bd90) at gc.c:233
        nvfsid = <optimized out>
        event_data = {vclass = 0x56265ec14e20 <extfs_subclass>, id = 0x56265f54bd90, ret = 0}
        vpath = 0x56265f4ad930
        path_element = 0x56265f54e2d0
#17 0x000056265eb91cd4 in extfs_close (fh=0x56265f50ebc0) at extfs.c:1002
        file = <optimized out>
        errno_code = 0
#18 0x000056265eb7a99c in mc_close (handle=100) at interface.c:410
        vfs = 0x56265ec14e20 <extfs_subclass>
        fsinfo = 0x56265f50ebc0
        result = <optimized out>
#19 0x000056265eb7aa17 in cpio_free_archive (me=<optimized out>, super=0x56265f546170) at cpio.c:217
        arch = 0x56265f546170
#20 0x000056265eb7b34d in vfs_s_free_super (me=0x56265ec16060 <cpio_subclass>, super=0x56265f546170) at direntry.c:351
No locals.
#21 0x000056265eb3eca6 in vfs_expire (now=0) at gc.c:293
        stamping = 0x56265f5379e0
        curr_time = {tv_sec = 1570315131, tv_usec = 541831}
        exp_time = <optimized out>
        stamp = 0x56265f510f00 = {0x56265f5379e0}
        locked = <optimized out>
        curr_time = <optimized out>
        exp_time = <optimized out>
        stamp = <optimized out>
        stamping = <optimized out>
--Type <RET> for more, q to quit, c to continue without paging--
#22 vfs_expire (now=0) at gc.c:251
        curr_time = <optimized out>
        exp_time = <optimized out>
        stamp = <optimized out>
        locked = 1
        stamping = <optimized out>
#23 0x000056265eb66351 in vfs_timeout_handler () at gc.c:323
No locals.
#24 tty_get_event (event=0x7ffefb8b3ebc, redo_event=0, block=1) at key.c:2053
        __d = <optimized out>
        seconds = <optimized out>
        __d = <optimized out>
        __d = <optimized out>
        _y = <optimized out>
        __d = <optimized out>
        __d = <optimized out>
        __d = <optimized out>
        nfd = <optimized out>
        status = <optimized out>
        select_set = {fds_bits = {0 <repeats 16 times>}}
        _x = <optimized out>
        c = <optimized out>
        flag = 0
        time_out = {tv_sec = 0, tv_usec = 0}
        time_addr = 0x7ffefb8b3dd8
        dirty = 1
        ev = {buttons = 0 '\000', modifiers = 0 '\000', vc = 0, dx = 0, dy = 0, x = 0, y = 0, type = (unknown: 0), clicks = 0, margin = (unknown: 0), wdx = 0, wdy = 0}
#25 0x000056265eb785f1 in frontend_dlg_run (h=0x56265f581ea0) at dialog.c:542
        d_key = <optimized out>
        wh = 0x56265f581ea0
        event = {buttons = 202 '\312', modifiers = 183 '\267', vc = 51160, dx = 7840, dy = 24408, x = -1, y = 0, type = (unknown: 0), clicks = 0, 
          margin = (unknown: 1599610528), wdx = 22054, wdy = 0}
#26 dlg_run (h=0x56265f581ea0) at dialog.c:1197
--Type <RET> for more, q to quit, c to continue without paging--
No locals.
#27 0x000056265ebbd71b in mcview_viewer (command=0x0, file_vpath=<optimized out>, start_line=0, search_start=0, search_end=0) at mcviewer.c:255
        succeeded = 1
        lc_mcview = 0x56265f582b00
        view_dlg = 0x56265f581ea0
#28 0x000056265ebbfd3b in view_file_at_line (filename_vpath=0x56265f5814b0, plain_view=0, internal=<optimized out>, start_line=0, search_start=0, search_end=0)
    at cmd.c:572
        view_entry = "View\000\000\000\000\353\003\000\000\000\000\000\000\267\023\274^&V\000\000\204+\276^&V\000\000e\000\000\000\000\000\000\000`\022S_&V\000\000\f\000\000\000\000\000\000\000\353\003\000\000\000\000\000"
        ret = <optimized out>
        viewer = 0x0
#29 0x000056265ebbff25 in view_file (internal=<optimized out>, plain_view=0, filename_vpath=0x56265f5814b0) at cmd.c:608
No locals.
#30 do_view_cmd (normal=0) at cmd.c:157
        file_idx = <optimized out>
        filename_vpath = 0x56265f5814b0
#31 0x000056265ebc4fe8 in view_cmd () at cmd.c:618
No locals.
#32 midnight_execute_cmd (sender=0x56265f532400, command=101) at midnight.c:1372
        res = MSG_HANDLED
#33 0x000056265eb62249 in buttonbar_callback (w=0x56265f532400, sender=<optimized out>, msg=<optimized out>, parm=1003, data=<optimized out>) at buttonbar.c:171
        bb = 0x56265f532400
        i = 2
        width = <optimized out>
        text = <optimized out>
#34 0x000056265eb78308 in dlg_try_hotkey (d_key=1003, h=0x56265f518090) at dialog.c:437
        hot_cur = 0x56265f514340 = {0x56265f532400, 0x56265f531c40, 0x56265f531260}
        current = <optimized out>
        handled = MSG_NOT_HANDLED
        c = 1003
#35 dlg_key_event (d_key=1003, h=0x56265f518090) at dialog.c:482
        handled = <optimized out>
#36 dlg_process_event (h=0x56265f518090, key=1003, event=<optimized out>) at dialog.c:1164
--Type <RET> for more, q to quit, c to continue without paging--
No locals.
#37 0x000056265eb785fe in frontend_dlg_run (h=0x56265f518090) at dialog.c:544
        d_key = <optimized out>
        wh = 0x56265f518090
        event = {buttons = 38 '&', modifiers = 86 'V', vc = 0, dx = 6, dy = 0, x = -1, y = 0, type = GPM_MOVE, clicks = 0, margin = (unknown: 0), wdx = 0, wdy = 0}
#38 dlg_run (h=0x56265f518090) at dialog.c:1197
No locals.
#39 0x000056265eb3d3f6 in do_nc () at midnight.c:1783
        ret = <optimized out>
        ret = <optimized out>
#40 main (argc=<optimized out>, argv=<optimized out>) at main.c:409
        mcerror = 0x0
        config_migrated = <optimized out>
        config_migrate_msg = <optimized out>
        exit_code = 1
(gdb)

Change History

comment:1 Changed 7 weeks ago by andrew_b

  • Description modified (diff)

comment:2 Changed 7 weeks ago by andrew_b

  • Status changed from new to closed
  • Version changed from master to 4.8.23
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #4023.

Note: See TracTickets for help on using tickets.