Ticket #3896 (closed defect: worksforme)

Opened 22 months ago

Last modified 22 months ago

mcedit can not show "/dev/null"

Reported by: fragzone Owned by:
Priority: major Milestone:
Component: mcedit Version: master
Keywords: Cc: egmont
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

I try to copy this code to mcedit:

#!/bin/bash

wget -O /dev/null -o /dev/null "url"

mcedit shows only:

#!/bin/bash

wget -O -o "url"

System: debian stable
Windows / Putty

Attachments

mcedit.png (18.7 KB) - added by fragzone 22 months ago.
cat.png (33.0 KB) - added by fragzone 22 months ago.

Change History

Changed 22 months ago by fragzone

Changed 22 months ago by fragzone

comment:1 Changed 22 months ago by fragzone

  • Component changed from mc-core to mcedit

comment:2 in reply to: ↑ description Changed 22 months ago by andrew_b

Replying to fragzone:

System: debian stable

$ slocate libastal.so
<empty>

Please show the output of mc -V.

Windows / Putty

comment:3 Changed 22 months ago by fragzone

Debian:

GNU Midnight Commander 4.8.18
Kompiliert mit GLib 2.50.0
Benutze die S-Lang Bibliothek mit der terminfo-Datenbank
Mit eingebautem Editor
Mit optionaler Subshell-Unterstützung als Standard
Mit Unterstützung für Hintergrundtätigkeiten
Mit Maus-Unterstützung im xterm und der Linux-Konsole
Mit Unterstützung für X11-Ereignisse
Mit Internationalisierungs-Unterstützung
Mit mehrfach Codepage-Unterstützung
Virtuelles Dateisystem: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, sftpfs, fish
Datentyp: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

UBUNTU:
GNU Midnight Commander 4.8.15
Built with GLib 2.47.3
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, sftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Both systems same result

comment:4 Changed 22 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to worksforme
  • Milestone Future Releases deleted

Cannot reproduce on system other than Debian.
Current mc version is 4.8.20.
Please try the resent version or file a bug in Debian bugzilla.

comment:5 Changed 22 months ago by fragzone

I find the issue.

mcedit use for "/dev/null" a color, that "putty" translate in same color like background color.

Putty use ANSI-Colours. The blue from "/dev/null" is only a little bit different from background blue.
For ANSI 256 Colors is this blue same same.

You can change the special color from "/dev/null" to a brighter blue.

comment:6 Changed 22 months ago by egmont

  • Cc egmont added

I can reproduce with 4.8.20 (compiled by myself) on Ubuntu Artful, in gnome-terminal, with TERM=xterm, and of course mc's default skin. With TERM=xterm-256color it's a slightly different shade of blue.

Note: See TracTickets for help on using tickets.