Ticket #2909 (closed defect: duplicate)

Opened 8 years ago

Last modified 8 years ago

mc not doing directory completion when using the tilde character.

Reported by: tempUser Owned by:
Priority: minor Milestone:
Component: mc-core Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Since the last version (or maybe the one before that), mc has stopped doing completion when using the tilde character for the home directory.

For example:

  1. In the command line below mc, type cd ~/
  2. Press Alt-Tab
  3. Nothing Happens!

Earlier it used to work fine.

Same happens when using ~ with mc's copy/move and probably other operations too.

$ mc --configure-options

'--prefix=/usr' '--sysconfdir=/etc' '--mandir=/usr/share/man' '--enable-background' '--enable-charset' '--enable-largefile' '--with-edit' '--with-gpm-mouse' '--with-mmap' '--enable-vfs-smb' '--with-screen=slang' '--with-subshell' '--with-vfs' '--with-x' '--without-debug' '--without-gnome' '--without-included-gettext' '--libexecdir=/usr/lib' 'CFLAGS=-march=i686 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2' 'LDFLAGS=-Wl,-O1,--sort-common,--as-needed,-z,relro'

$ mc -V
GNU Midnight Commander 4.8.6
Built with GLib 2.32.4
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, fish, smbfs
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

Change History

comment:1 follow-up: ↓ 2 Changed 8 years ago by andrew_b

  • Status changed from new to closed
  • Version 4.8.6 deleted
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Why you didn't use search?

Duplicate of #2898.

comment:2 in reply to: ↑ 1 Changed 8 years ago by tempUser

Replying to andrew_b:

Why you didn't use search?

Duplicate of #2898.

Sorry I only searched the open bugs :P

Great work on fixing it quickly as always.

Note: See TracTickets for help on using tickets.