Ticket #2065 (closed defect: invalid)

Opened 10 years ago

Last modified 9 years ago

mc crashes when entering a deb file created from mc

Reported by: Graham Owned by:
Priority: major Milestone: 4.7
Component: mc-vfs Version: 4.7.1
Keywords: Cc: zaytsev
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

This is a weird one. If you enter a deb file, you can navigate around the file and view its contents fine. Now, if you have created a deb file from mc or go and get an official mc deb package from, say, Debian's repository, then you navigate to #deb/CONTENTS/usr/bin with the latest mc (4.7.1), mc will crash. mc 4.7.0.3 isn't affected by this bug, and I can navigate through the same deb file just fine. Again, this doesn't seem to affect deb files of other packages, just mc's.

Steps to reproduce:

1 - Go and get an mc deb file from Debian (http://ftp.uk.debian.org/debian/pool/main/m/mc/mc_4.7.0.1-1_i386.deb)

2 - With mc 4.7.1, go to the file downloaded (in our case, mc_4.7.0.1-1_i386.deb)

3 - Enter into the file, you'll see the directory structure

4 - Now navigate to #deb/CONTENTS/usr/bin (going to other directories in the deb file doesn't seem to crash mc)

5 - Watch mc crash

6 - Restart mc and get another deb that's not *mc* and has a /usr/bin directory inside (I chose http://ftp.uk.debian.org/debian/pool/main/m/mawk/mawk_1.3.3-11.1_i386.deb)

7 - Enter the package and navigate to #deb/CONTENTS/usr/bin

8 - Contents will be displayed and mc will work fine

This is only happening for mc 4.7.1. Version 4.7.0.3 works fine in respect to this bug. Also this crash also happens when I navigate through my own created mc deb packages, so it's not just an issue with the packages found at the Debian repository mentioned above, but seemingly any deb file that is created from mc.

I'm using Debian Lenny and compiled 4.7.1 with the following options: ./configure --with-glib2 --without-ext2undel --enable-charset --without-samba --with-screen=slang

Attachments

gdb.txt (6.1 KB) - added by david_sastre 9 years ago.

Change History

comment:1 Changed 10 years ago by Graham

Well, thought I'd do some more testing on this one. Let me stress, I'm not installing the deb file I mention or creating a deb file and installing that, the mc I'm using is a simple ./configure (with some options), make, make install. What I'm doing is entering the mc deb file and viewing its contents using my own compiled mc 4.7.1.

I tried with another deb file from Ubuntu's Dapper Drake (http://fr.archive.ubuntu.com/ubuntu/pool/universe/m/mc/mc_4.6.1-1ubuntu2_i386.deb), but found the same problem: when you enter CONTENTS/usr/bin and try to look inside the directory's contents, mc aborts. Doing so with another deb package of another application doesn't cause an issue; this just seems to affect mc deb packages.

I then tried with an RPM package file (ftp://ftp.sunet.se/pub/os/Linux/distributions/fedora/linux/releases/10/Everything/i386/os/Packages/mc-4.6.2-7.pre1.fc10.i386.rpm), but had no problem with that package at all when entering it and going to CONTENTS.cpio/usr/bin.

Version 4.7.0.3 works fine, this just seems to affect 4.7.1.

Sorry for the extra noise, but thought I'd add the above to give clarity.

comment:2 follow-up: ↓ 3 Changed 9 years ago by Graham

Just to add that someone else seems to have suffered a similar issue to the one I reported in this bug ticket (it might not be exact, but it seems similar enough). The problem is that the reporter seems to have only added a report via the mc-bugs Google Groups rather than the bug ticket system here, so maybe it's not being noticed. Link to the bug report in mc-bugs below:

http://groups.google.com/group/mc-bugs/browse_thread/thread/2248fefd6db3eca8#

Changed 9 years ago by david_sastre

comment:3 in reply to: ↑ 2 Changed 9 years ago by david_sastre

Replying to Graham:
I already reported via mc-bugs (link above).
This is just for the record:
I'm running Linux 2.6.26-2-686-bigmem SMP Tue Mar 9 18:01:52 UTC 2010 i686 GNU/Linux.

This is how to can reproduce it:
-start mc
-navigate into any .deb package
-enter /usr/bin inside the deb package.
-mc crashes.

I can reproduce it with atool_0.37.0-1_all.deb (contains /usr/bin structure)
but not with cnijfilter-common_3.00-1_i386.deb (although it contains /usr/bin)
Packages not having /usr/bin can be browsed without problem.

gdb session output attached.

comment:4 follow-up: ↓ 8 Changed 9 years ago by slavazanko

  • Status changed from new to closed
  • Resolution set to invalid

I installed 'debootstrap' utility (and set up chroot'ed Sid), next I made some tests...

david_sastre: well, on 4.7.1 version segfault is present, but in master now all okay... After bisecting I found fix-commit: 68d7a772109af00717b7c552e26bba32ce4c1537

You may apply it on your 4.7.1 sources or just await for next version of mc (will release at few days).

Graham: check this commit too (if it's possible to you). Now this ticket closed as 'invalid', but if segfault still after applying patch from commit - reopen please.

comment:5 Changed 9 years ago by zaytsev

  • Cc zaytsev added

Question: can this be backported to stable as supposedly it still has this crasher? I can do this if you want.

comment:6 Changed 9 years ago by slavazanko

For stable changeset:3a076f439e65616e225023fd0afc072a44517aac
Already cherry-picked. Bug was fixed in #1909

comment:7 Changed 9 years ago by zaytsev

Cool, thanks!

comment:8 in reply to: ↑ 4 Changed 9 years ago by Graham

Replying to slavazanko:

Graham: check this commit too (if it's possible to you). Now this ticket closed as 'invalid', but if segfault still after applying patch from commit - reopen please.

Just to confirm, the commit you mention fixes this issue for me. Thanks.

Note: See TracTickets for help on using tickets.