Ticket #1453 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

Crash on Shift-F4 press

Reported by: smart Owned by: angel_il
Priority: major Milestone: 4.7.0-pre2
Component: mcedit Version: master
Keywords: Cc: isee@…
Blocked By: Blocking:
Branch state: Votes for changeset: committed-master

Description

Steps to reproduce:

  1. Press Shift-F4 while on the panels

There will be an error popup entitled "Internal Error"
and saying "Cannot canonicalize NULL",
then mc will crash and exit abnormally not cleaning the screen.

Attachments

mc-shift-f4-bug-configure.log (21.7 KB) - added by smart 10 years ago.
configure log on gentoo-current

Change History

comment:1 Changed 10 years ago by smart

  • Cc isee@… added
  • Version changed from 4.7.0-pre1 to master

comment:2 follow-up: ↓ 3 Changed 10 years ago by iNode

Replying to smart:

Steps to reproduce:

  1. Press Shift-F4 while on the panels

There will be an error popup entitled "Internal Error"
and saying "Cannot canonicalize NULL",
then mc will crash and exit abnormally not cleaning the screen.

Can't reproduce, describe more detailed. Also please provide backtrace if you can (how to do it described in FAQ, pt 10.3).

comment:3 in reply to: ↑ 2 Changed 10 years ago by iNode

And describe configure options that you use.

comment:4 Changed 10 years ago by angel_il

please tell more about your enviroment, OS, etc...

Changed 10 years ago by smart

configure log on gentoo-current

comment:5 Changed 10 years ago by smart

I'm using the Gentoo [current] with the stock mc-9999.ebuild from the git repo

I've attached the configure log to the topic

comment:6 follow-up: ↓ 7 Changed 10 years ago by smart

Note also that no segmentation faults were made -- so gdb can't get the stack trace.
It just says:

Program exited with code 01.
(gdb) where
No stack.

comment:7 in reply to: ↑ 6 Changed 10 years ago by iNode

It's seems to be vfs error message, what vfs you use in this case?
Please describe how to reproduce more detailed.

You also can describe it in russian in mc-dev@….

comment:8 Changed 10 years ago by smart

No vfs. Just my home dir on both panels. No matter where cursor is while pressing.
I can reproduce it every time -- doesn't work like a charm :)

Are there any other gentoo users who could try this?

comment:9 Changed 10 years ago by smart

IMPORTANT ADDITION


Okay, an investigation has shown that in order to reproduce
an internal editor should be turned off in the Options.

I use EDITOR=vim though it shouldn't be crucial.

comment:10 Changed 10 years ago by angel_il

  • Owner set to angel_il
  • Status changed from new to accepted
  • Milestone changed from 4.7 to 4.7.0-pre2

comment:11 Changed 10 years ago by angel_il

  • Status changed from accepted to assigned
  • severity changed from no branch to on review

branch: 1453_mc_crash_after_f14 parent: master
changeset: 3b1070fb3d29569b56932aca2268874c56e0d9fc

comment:12 Changed 10 years ago by iNode

  • Votes for changeset set to iNode

comment:13 Changed 10 years ago by slavazanko

  • Votes for changeset changed from iNode to iNode slavazanko
  • Component changed from mc-core to mcedit
  • severity changed from on review to approved

comment:14 Changed 10 years ago by angel_il

  • Status changed from assigned to testing
  • Votes for changeset changed from iNode slavazanko to commited-master
  • Resolution set to fixed
  • severity changed from approved to merged

comment:15 Changed 10 years ago by angel_il

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.