Ticket #1434 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

segfault in viewer

Reported by: iNode Owned by:
Priority: major Milestone: 4.7.0-pre3
Component: mcview Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description

Open in viewer some big gzipped file i.e. apache log.
Go to end of file, go to begin of file, quit viewer.

Traceback:

(gdb) bt
#0  0x0808a6fe in view_done (view=0x9a7c488) at view.c:746
#1  0x0808d867 in view_callback (w=0x9a7c488, msg=WIDGET_DESTROY, parm=0) at view.c:3919
#2  0x08058ad0 in dlg_broadcast_msg (h=0x9a70a38, message=WIDGET_DESTROY, reverse=0) at dialog.h:207
#3  0x080591a4 in destroy_dlg (h=0x9a70a38) at dialog.c:834
#4  0x0808d1bb in mc_internal_viewer (command=0x9a8a618 "/bin/sh /tmp/mc-pashelper/mcextZfttBd", 
    file=0x9a8a680 "access.log.2.gz", move_dir_p=0xbf8df3c4, start_line=0) at view.c:3841
#5  0x0805c107 in exec_extension (filename=0x9a8a680 "access.log.2.gz", data=<value optimized out>, 
    move_dir=0xbf8df3c4, start_line=0) at ext.c:248
#6  0x0805cc1d in regex_command (filename=0x9a739d8 "access.log.2.gz", action=0xbf8df3c8 "View", 
    move_dir=0xbf8df3c4) at ext.c:608
#7  0x080552f8 in view_file_at_line (filename=0x9a739d8 "access.log.2.gz", plain_view=0, internal=1, 
    start_line=0) at cmd.c:150
#8  0x080553b7 in view_file (filename=0x9a739d8 "access.log.2.gz", plain_view=0, internal=1) at cmd.c:178
#9  0x0805543d in do_view_cmd (normal=0) at cmd.c:236
#10 0x0808e603 in buttonbar_call (bb=0x0, i=<value optimized out>) at widget.c:2423
#11 0x0808efc3 in buttonbar_callback (w=0x9a716b0, msg=WIDGET_HOTKEY, parm=1003) at widget.c:2454
#12 0x08059475 in dlg_process_event (h=0x9a6ac28, key=1003, event=0xbf8df500) at dialog.c:628
#13 0x08059717 in run_dlg (h=0x9a6ac28) at dialog.c:808
#14 0x08071863 in main (argc=Cannot access memory at address 0x21
) at main.c:1797

Change History

comment:1 Changed 9 years ago by iNode

  • Milestone changed from 4.7 to 4.7.0-pre2

comment:2 Changed 9 years ago by angel_il

  • Milestone changed from 4.7.0-pre2 to 4.7

comment:3 Changed 9 years ago by andrew_b

  • Component changed from mc-core to mcview
  • Milestone changed from 4.7 to 4.7.0-pre3

Does this bug present in 4.7.0-pre2?

comment:4 Changed 9 years ago by iNode

Yes, it's still reproductible.

comment:5 Changed 9 years ago by angel_il

i can't reproduce it.

comment:6 Changed 9 years ago by iNode

Me to at that moment. Maybe it was fixed in the other ticket.

comment:7 Changed 9 years ago by angel_il

  • Status changed from new to closed
  • Resolution set to fixed

It's fixed by one of the related tickets

Note: See TracTickets for help on using tickets.