Ticket #1420 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

./configure issue: Glib

Reported by: zaytsev Owned by: slavazanko
Priority: major Milestone: 4.7.0-pre3
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: Votes for changeset: andrew_b angel_il

Description (last modified by zaytsev) (diff)

Hi!

I'm trying to get RHEL4 mc builds rolling. RHEL4 a widely deployed server distro which recently got updated to 4.7, so it is one of the important targets for mc/ssh. Basically the buildlog is here:

http://nopaste.com/p/aW0XbKvEV

Now check this out:

checking for GLIB... Requested 'glib-2.0 >= 2.6' but version of GLib is 2.4.7
no

The GLib version shipped with RHEL4.7 is in fact glib2-2.4.7-1.i386.rpm , but instead of aborting at glib-2.0 >= 2.6 the ./configure process goes on.

Change History

comment:1 Changed 10 years ago by zaytsev

I will address the EL4 issue in a separate ticket.

comment:2 Changed 10 years ago by zaytsev

  • Description modified (diff)

comment:3 Changed 10 years ago by zaytsev

  • Summary changed from Glib ./configure issue to ./configure issue: Glib

comment:4 Changed 10 years ago by angel_il

  • Milestone changed from 4.7.0-pre2 to 4.7.0-pre3

comment:5 Changed 10 years ago by slavazanko

  • Owner set to slavazanko
  • Status changed from new to accepted
  • severity changed from no branch to on review

created branch 1420_configure_issue_glib (parent: master)

Initial changeset:aece330708a522ef0703f497b3f549583b513f4b

review, please.

comment:6 Changed 10 years ago by zaytsev

Maybe old/incompatible, but not bad? Glib can't be bad ;-)

comment:7 Changed 10 years ago by slavazanko

"glib-2.0 not found or version too old"

right?

comment:8 Changed 10 years ago by zaytsev

Sounds good to me!

comment:9 Changed 10 years ago by slavazanko

review changeset:7181f8b6bb97a67e9ce012c0608b6921c3439ac7

BTW, you may vote fot this branch (you ticketstarter).

Check if bug is avoid before :)

comment:10 Changed 10 years ago by iNode

It's not descriptive error message isn't error should report minimal required version of libglib-2?

comment:11 Changed 10 years ago by slavazanko

Added minimal version number into error output.

changeset:b0013c8a828364cd1d50f869328fde07434f42c2

review

comment:12 Changed 10 years ago by andrew_b

  • Votes for changeset set to andrew_b

comment:13 Changed 10 years ago by angel_il

  • Votes for changeset changed from andrew_b to andrew_b angel_il
  • severity changed from on review to approved

comment:14 Changed 10 years ago by slavazanko

  • Status changed from accepted to testing
  • Resolution set to fixed

comment:15 Changed 10 years ago by slavazanko

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.