Ticket #4321 (closed defect: invalid)

Opened 2 years ago

Last modified 2 years ago

No syntax highlight rules available despite ~/.config/mc/mcedit/Syntax present, but works when run with sudo

Reported by: dandv Owned by:
Priority: major Milestone:
Component: mcedit Version: 4.8.24
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:


If I run mc(edit) as my user, it doesn't do any syntax highlight. "Options -> Syntax highlight" only shows "Auto" and "Reload Current Syntax", but "Options -> Syntax file" opens ~/.config/mc/mcedit/Syntax successfully (I tried deleting that file and it was recreated).

If I run sudo mc, syntax highlight works.

I suppose the files included from ~/.config/mc/mcedit/Syntax aren't found, but they do exist in /usr/share/mc/syntax, and are readable by the current user.

I don't see any error anywhere that would help me solve this problem. mcedit could output a warning in the terminal (Ctrl+O) to help the user figure out how to fix the problem.

Change History

comment:1 in reply to: ↑ description Changed 2 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to invalid
  • Milestone Future Releases deleted

Replying to dandv:

If I run sudo mc, syntax highlight works.

Looks like your files under ~/.config/mc are owned by root and $USER haven't rights to read them.
Please check permissions for all mc configuration files in your $HOME. Also please check the sudo configuration. See #2730 for details.

Note: See TracTickets for help on using tickets.