Changes between Initial Version and Version 19 of Ticket #86


Ignore:
Timestamp:
01/11/14 23:04:15 (9 years ago)
Author:
ossi
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #86

    • Property Status changed from new to closed
    • Property Votes for changeset changed from to committed-master committed-stable
    • Property Severity changed from to no branch
    • Property Reporter changed from slavazanko to nijman
    • Property Resolution changed from to fixed
    • Property Version changed from to master
    • Property Branch state changed from to merged
    • Property Milestone changed from to 4.8.2
    • Property Owner set to angel_il
  • Ticket #86 – Description

    initial v19  
    77||Release:||4.6.2-pre1||Operating System:||Other|| 
    88 
    9 Discussion: 
     9Original submission: 
    1010{{{ 
    11 Thu 18 Dec 2008 11:17:09 AM UTC, comment #9: 
     11On openSuse 11 starting mc takes a very long time: about 30s. IpV6  
     12is disabled but VMware player is installed and so virtual network  
     13devices are present. 
    1214 
    13 If this helps: I have some NFS mounted drives but none of them if in 
    14  one of the mc panes. 
    15         Sorin Sbarnea <sorin> 
    16 Thu 18 Dec 2008 10:58:47 AM UTC, comment #8: 
     15nslookup and netstat work immidiately so it isn't the gethostbyname  
     16issue. 
    1717 
    18 I would like to add that I have the same problem with version  
    19 4.6.1-pre1a and that "options no_tld_query" in resolv.conf does not  
    20 work (tested even after system restart) 
    21         Sorin Sbarnea <sorin> 
    22 Thu 18 Dec 2008 10:48:06 AM UTC, comment #7: 
     18A solution would be greatly appreciated. 
     19}}} 
    2320 
     21Comment 1 by Oswald Buddenhagen <ossi> at Tue 12 Aug 2008 10:07:17 AM UTC: 
     22{{{ 
     23you should attach the strace of such a startup. 
     24}}} 
     25 
     26Comment 2 by Ies Nijman <nijman> at Tue 12 Aug 2008 11:26:57 AM UTC: 
     27{{{ 
     28Strace output added. Funny thing is that with strace, MC starts up  
     29rightaway... 
     30 
     31(file #16277) 
     32}}} 
     33 
     34Comment 3 by Ies Nijman <nijman> at Tue 12 Aug 2008 12:43:53 PM UTC: 
     35{{{ 
     36Previous results were from MC 4.6.1 (fast starting). 
     37 
     38Next slow results from MC 4.6.2 and a strace file. 
     39}}} 
     40 
     41Comment 4 by Ies Nijman <nijman> at Tue 12 Aug 2008 02:28:09 PM UTC: 
     42{{{ 
     43New strace file attached, now with timestamps. 
     44 
     45It seems to timeout several times on 
     46"RESOLVE-HOSTNAME-IPV4" 
     47 
     48Strange because if I do nslookup with this host name it returns  
     49immediately.. 
     50 
     51(file #16281) 
     52}}} 
     53 
     54Comment 5 by Irakli <ika256> at Wed 03 Sep 2008 07:29:31 AM UTC: 
     55{{{ 
     56I had this problem too 
     57Solution is: 
     58add "options no_tld_query" in resolv.conf 
     59}}} 
     60 
     61Comment 6 by Sorin Sbarnea <sorin> at Tue 07 Oct 2008 10:54:29 AM UTC: 
     62{{{ 
     63I can confirm the same issue on multiple platform: OS X, Fedora and Ubuntu. 
     64 
     65It's a real pain and this should be solved inside mc - mc is used as 
     66a configuration tools and it's supposed to work even on systems  
     67where configuration is not "well done". 
     68 
     69BTW. The solution with "options no_tld_query" in resolv.conf does  
     70not solves the problem in my case. 
     71 
     72I don't remember exactly but I think it's somewhat related to  
     73/etc/hosts 
     74}}} 
     75 
     76Comment 7 by Sorin Sbarnea <sorin> at Thu 18 Dec 2008 10:48:06 AM UTC: 
     77{{{ 
    2478I can (re)confirm this problem on RHEL also. 
    2579 
     
    3387If you are searching on google after "midnight commander slow start" 
    3488 you'll see that a lot of people are encountering this issue. 
    35         Sorin Sbarnea <sorin> 
    36 Tue 07 Oct 2008 10:54:29 AM UTC, comment #6: 
     89}}} 
    3790 
    38 I can confirm the same issue on multiple platform: OS X, Fedora and Ubuntu. 
     91Comment 8 by Sorin Sbarnea <sorin> at Thu 18 Dec 2008 10:58:47 AM UTC: 
     92{{{ 
     93I would like to add that I have the same problem with version  
     944.6.1-pre1a and that "options no_tld_query" in resolv.conf does not  
     95work (tested even after system restart) 
     96}}} 
    3997 
    40 It's a real pain and this should be solved inside mc - mc is used as 
    41 a configuration tools and it's supposed to work even on systems  
    42 where configuration is not "well done". 
    43  
    44 BTW. The solution with "options no_tld_query" in resolv.conf does  
    45 not solves the problem in my case. 
    46  
    47 I don't remember exactly but I think it's somewhat related to  
    48 /etc/hosts 
    49         Sorin Sbarnea <sorin> 
    50 Wed 03 Sep 2008 07:29:31 AM UTC, comment #5: 
    51  
    52 I had this problem too 
    53 Solution is: 
    54 add "options no_tld_query" in resolv.conf 
    55         Irakli <ika256> 
    56 Tue 12 Aug 2008 02:28:09 PM UTC, comment #4: 
    57  
    58 New strace file attached, now with timestamps. 
    59  
    60 It seems to timeout several times on 
    61 "RESOLVE-HOSTNAME-IPV4" 
    62  
    63 Strange because if I do nslookup with this host name it returns  
    64 immediately.. 
    65  
    66 (file #16281) 
    67         Ies Nijman <nijman> 
    68 Tue 12 Aug 2008 12:43:53 PM UTC, comment #3: 
    69  
    70 Previous results were from MC 4.6.1 (fast starting). 
    71  
    72 Next slow results from MC 4.6.2 and a strace file. 
    73         Ies Nijman <nijman> 
    74 Tue 12 Aug 2008 11:26:57 AM UTC, comment #2: 
    75  
    76 Strace output added. Funny thing is that with strace, MC starts up  
    77 rightaway... 
    78  
    79 (file #16277) 
    80         Ies Nijman <nijman> 
    81 Tue 12 Aug 2008 10:07:17 AM UTC, comment #1: 
    82  
    83 you should attach the strace of such a startup. 
    84         Oswald Buddenhagen <ossi> 
    85 Mon 11 Aug 2008 03:21:54 PM UTC, original submission: 
    86  
    87 On openSuse 11 starting mc takes a very long time: about 30s. IpV6  
    88 is disabled but VMware player is installed and so virtual network  
    89 devices are present. 
    90  
    91 nslookup and netstat work immidiately so it isn't the gethostbyname  
    92 issue. 
    93  
    94 A solution would be greatly appreciated. 
     98Comment 9 by Sorin Sbarnea <sorin> at Thu 18 Dec 2008 11:17:09 AM UTC: 
     99{{{ 
     100If this helps: I have some NFS mounted drives but none of them if in 
     101 one of the mc panes. 
    95102}}}