Ticket #53 (closed defect: fixed)

Opened 10 years ago

Last modified 5 years ago

savannah: fish when accessing hardlinks, will bail out

Reported by: mikeys Owned by:
Priority: major Milestone: 4.6.2
Component: mc-vfs Version:
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description (last modified by ossi) (diff)

Original: http://savannah.gnu.org/bugs/index.php?18087

Submitted by:Michal Szwaczko <mikeys>Submitted on:Mon 23 Oct 2006 05:06:04 AM UTC
Category:VFSSeverity:3 - Normal
Status:NonePrivacy:Public
Assigned to:NoneOpen/Closed:Open
Release:All versionsOperating System:GNU/Linux

Original submission:

in fish, when copying a large tree of files over from a remote 
host, if a file is a hardlink, fish hangs when coming across this 
file, nothing more gets copied. seems like fish does not see that 
the file is a hardlink and does not follow it, just bails out 
without warning and hangs, the rest of the files which were to be 
copied never get through. 

Comment 1 by hajma <tropikhajma> at Tue 17 Jun 2008 07:57:12 PM UTC:

still valid with GNU Midnight Commander 4.6.2-pre1 on Mandriva 
Linux 2008.1/x86_32

Change History

comment:1 Changed 10 years ago by winnie

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone set to 4.6.2

Changing milestone to 4.6.2.. at least this error is unreproducible with the mc which is currently in mc-4.6 branch, so I guess this issue is fixed (because of our restructurments of the fish.c code).

comment:2 Changed 5 years ago by ossi

  • Description modified (diff)
  • Branch state set to no branch
  • Reporter changed from slavazanko to mikeys
Note: See TracTickets for help on using tickets.