Ticket #4554 (closed defect: duplicate)

Opened 4 weeks ago

Last modified 4 weeks ago

Ctrl-Fx and Shift-Fx keyboard shortcuts don't seem to work

Reported by: ilson Owned by:
Priority: major Milestone:
Component: mc-tty Version: 4.8.31
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

  1. Create a file ~/.config/mc/mc.keymap and put these lines into it:
[filemanager]
Find = ctrl-f7; shift-f7
  1. Open MC and try pressing Ctrl+F7 or Shift+F7. Neither shortcut seems to work.

"LC_MESSAGES=C mc -V" output:

GNU Midnight Commander 4.8.31
Built with GLib 2.78.4
Built with S-Lang 2.3.3 with terminfo database
Built with libssh2 1.11.0
With builtin Editor and Aspell support
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
With ext2fs attributes support
Virtual File Systems:
 cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, shell
Data types:
 char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

"LC_MESSAGES=C mc -F" output:

Home directory: /home/ilf
Profile root directory: /home/ilf

[System data]
    Config directory: /etc/mc/
    Data directory:   /usr/share/mc/
    File extension handlers: /usr/lib/mc/ext.d/
    VFS plugins and scripts: /usr/lib/mc/
	extfs.d:        /usr/lib/mc/extfs.d/
	shell:          /usr/lib/mc/shell/

[User data]
    Config directory: /home/ilf/.config/mc/
    Data directory:   /home/ilf/.local/share/mc/
	skins:          /home/ilf/.local/share/mc/skins/
	extfs.d:        /home/ilf/.local/share/mc/extfs.d/
	shell:          /home/ilf/.local/share/mc/shell/
	mcedit macros:  /home/ilf/.local/share/mc/mc.macros
	mcedit external macros: /home/ilf/.local/share/mc/mcedit/macros.d/macro.*
    Cache directory:  /home/ilf/.cache/mc/

"mc --configure-options" output:

 '--prefix=/usr' '--libexecdir=/usr/lib' '--sysconfdir=/etc' '--enable-aspell' '--with-screen=slang' '--with-x' 'CFLAGS=-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions         -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security         -fstack-clash-protection -fcf-protection -g -ffile-prefix-map=/build/mc/src=/usr/src/debug/mc -flto=auto' 'LDFLAGS=-Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z,relro -Wl,-z,now          -Wl,-z,pack-relative-relocs -flto=auto'

OS: Arch Linux
Terminals I tried: UXTerm, GNOME terminal, GNOME console
Midnight Commander 4.8.31.

Additional info:
1) F9 -> "Command" shows (among other things) "Find file C-F7", that is the "mc.keymap" file is found and parsed.
2) Both Ctrl+F7 and Shift-F7 combinations work in Vim - for example, mappings like "map <C-F7> iCF7" and "map <S-F7> iSF7" work.

Please let me know if you need additional info.

Change History

comment:1 Changed 4 weeks ago by andrew_b

  • Status changed from new to closed
  • Component changed from mc-core to mc-tty
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2597.

comment:2 Changed 4 weeks ago by ilson

@andrew_b: Thank you, the method described at http://www.midnight-commander.org/ticket/2467#comment:6 works for Alt-Fn and Ctrl-Fn for me, but not for Shift-Fn for some reason...

comment:3 Changed 4 weeks ago by ilson

For people having that same problem: turns out for Shift-Fn keyboard shortcuts to work they must be specified as "f1n" in mc.keymap. For example, Shift-F7 should be specified as "f17" (and not "shift-f7").

Note: See TracTickets for help on using tickets.