Ticket #4451 (reopened defect)

Opened 16 months ago

Last modified 4 months ago

extended ACLs are not copied (copy, move)

Reported by: clemens Owned by:
Priority: minor Milestone: Future Releases
Component: mc-core Version: master
Keywords: acl,copy,move Cc:
Blocked By: #1852 Blocking:
Branch state: no branch Votes for changeset:

Description

Version:

GNU Midnight Commander 4.8.26
Built with GLib 2.66.8
Built with S-Lang 2.3.2 with terminfo database
With builtin Editor and Aspell support
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
With ext2fs attributes support
Virtual File Systems:
 cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, sftpfs, fish
Data types:
 char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Description

When using copy or move on the same file system or between file systems the set ACLs are not copied over

MC view:
Source

│ File: bar
│  Location:   10303h:21734h
│  Mode:       drwxrwxr-x (0775)
│  Attributes: -----------------e-------
│  Links:      2
│  Owner:      admin/admin
│  Size:       4096 (8 blocks)
│  Changed:    Mar 17 10:19
│  Modified:   Mar 17 09:40
│  Accessed:   Mar 17 10:19
│  Filesystem: /
│  Device:     /dev/nvme0n1p1
│  Type:       ext4 (10303h)
│  Free space: 29G/49G (58%)
│  Free nodes: 2850212/3268608 (87%)

Getfacl view:
On source folder

>$ getfacl bar
# file: bar
# owner: admin
# group: admin
user::rwx
group::r-x
group:staff:rwx
mask::rwx
other::r-x

After Copy/Move?
On target folder

>$ getfacl bar
# file: bar/
# owner: admin
# group: admin
user::rwx
group::rwx
other::r-x

MC View
On target folder

│ File: bar
│  Location:   10303h:2172Eh
│  Mode:       drwxrwxr-x (0775)
│  Attributes: -----------------e-------
│  Links:      2
│  Owner:      admin/admin
│  Size:       4096 (8 blocks)
│  Changed:    Mar 17 10:56
│  Modified:   Mar 17 09:40
│  Accessed:   Mar 17 10:19
│  Filesystem: /
│  Device:     /dev/nvme0n1p1
│  Type:       ext4 (10303h)
│  Free space: 29G/49G (58%)
│  Free nodes: 2850209/3268608 (87%)

Turning "Preserve attributes" on or off doesn't change the outcome

Change History

comment:1 Changed 16 months ago by andrew_b

  • Status changed from new to closed
  • Version changed from 4.8.26 to master
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2468.

comment:2 Changed 16 months ago by andrew_b

  • Status changed from closed to reopened
  • Resolution duplicate deleted
  • Milestone set to Future Releases

Sorry.

Reopened.

comment:3 Changed 4 months ago by andrew_b

  • Blocked By 1852 added
Note: See TracTickets for help on using tickets.