Ticket #4444 (closed defect: fixed)

Opened 13 months ago

Last modified 13 months ago

MD files not recognized as markdown files by extension

Reported by: wwp Owned by: andrew_b
Priority: trivial Milestone: 4.8.30
Component: mc-config-ini Version: 4.8.29
Keywords: markdown mc.ext.ini Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset: committed-master

Description (last modified by andrew_b) (diff)

What version of Midnight Commander is used?

2.4.29

Put output of mc -V command (and all other commands described in 'How to report about bugs') here.

 GNU Midnight Commander 4.8.29
 Built with GLib 2.56.1
 Built with S-Lang 2.2.4 with terminfo database
 Built with libssh2 1.8.0
 With builtin Editor and Aspell support
 With subshell support as default
 With support for background operations
 With mouse support on xterm and Linux console
 With support for X11 events
 With internationalization support
 With multiple codepages support
 With ext2fs attributes support
 Virtual File Systems:
  cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, fish
 Data types:
  char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

What steps will reproduce the problem?

Create or file a markdown file named foo.MD.
Select it, type ENTER to raise the default by-extension action over it.
Nothing happens.

Create or file a markdown file named foo.md.
Select it, type ENTER to raise the default by-extension action over it.
The default action for markdown files is happening.

What is the expected output?

The default action for markdown files.

What do you see instead?

Nothing, because mc.ext.ini wrongly says:

[markdown]
Regex=\.(md|mkd)$
ShellIgnoreCase=true
Include=editor

The issue is that it uses ShelIgnoreCase=true instead of RegexIgnoreCase=true
It should be:

[markdown]
Regex=\.(md|mkd)$
RegexIgnoreCase=true
Include=editor

Change History

comment:1 Changed 13 months ago by wwp

What version of Midnight Commander is used?

4.8.29

(sorry, some sort of dyslexia made me type a wrong version in the description above).

comment:2 Changed 13 months ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted
  • Description modified (diff)
  • Milestone changed from Future Releases to 4.8.30

comment:3 Changed 13 months ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset set to committed-master
  • Resolution set to fixed

comment:4 Changed 13 months ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.