Ticket #4420 (closed defect: fixed)

Opened 2 months ago

Last modified 6 weeks ago

MC fail to build with only SFTP network VFS future enabled

Reported by: Bishop Owned by: andrew_b
Priority: major Milestone: 4.8.29
Component: compilation Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

MC fail to build with futures like it:
"--enable-vfs-cpio --enable-vfs-tar --enable-vfs-sfs --enable-vfs-sftp --enable-vfs-extfs --disable-vfs-ftp --disable-vfs-smb --disable-vfs-fish --disable-vfs-undelfs"

The source of problem: no define ENABLE_VFS_NET with this params.

One point, that must be fixed: one of last lines m4.include/mc-vfs.m4 must be chaged to "if test x"$enable_vfs_ftp" = x"yes" -o x"$enable_vfs_sftp" = x"yes" -o x"$enable_vfs_fish" = x"yes"; then"

But there is no enough, somewhere else must be added this define for C compiler.

P.S. This problem confirmed in 4.8.26, 4.8.27 and 4.8.28 and looks like it is exist in trunk too.

Change History

comment:1 Changed 8 weeks ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted
  • Component changed from mc-core to mc-vfs

comment:2 Changed 8 weeks ago by andrew_b

  • Component changed from mc-vfs to compilation

comment:3 Changed 7 weeks ago by andrew_b

  • Branch state changed from no branch to on review

comment:4 Changed 6 weeks ago by andrew_b

  • Votes for changeset set to andrew_b
  • Branch state changed from on review to approved

comment:5 Changed 6 weeks ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:6 Changed 6 weeks ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.