Ticket #4408 (closed defect: fixed)

Opened 17 months ago

Last modified 11 months ago

long file list broken on exit from yes/no confirmation popup

Reported by: mrmazda Owned by: andrew_b
Priority: minor Milestone: 4.8.30
Component: mc-core Version: 4.8.28
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

To reproduce (e.g.):
1-configure right side pane with "listing format" -> "long file list"
2-select a directory in "right" side pane
3-F8
4-N

Actual behavior
0-yes/no confirmation popup appears (following F8)
1-left pane draws as if long file list had not been selected listing format
2-right pane shrinks to half window with partially visible content (left side hidden)

Expected behavior:
0-yes/no confirmation popup appears (following F8)
1-left pane remains hidden
2-right pane refreshes to full window width with selected directory having been removed

This is response to confirmation popups generally, not just to answering N to F8.
Observed on current versions of Tumbleweed, Fedora, Debian, Ubuntu plus Mageia beta.

Change History

comment:5 Changed 12 months ago by andrew_b

comment:7 Changed 12 months ago by mrmazda

"2-right pane refreshes to full window width with selected directory having been removed"
as expected behavior was supposed to have read:
2-right pane refreshes to full window width with previously selected directory remaining selected

comment:8 Changed 12 months ago by mrmazda

Last edited 12 months ago by mrmazda (previous) (diff)

comment:10 Changed 12 months ago by andrew_b

comment:11 Changed 12 months ago by andrew_b

Ticket #4449 has been marked as a duplicate of this ticket.

comment:12 Changed 12 months ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted
  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.30

comment:13 Changed 12 months ago by andrew_b

  • Votes for changeset set to andrew_b
  • Branch state changed from on review to approved

comment:14 Changed 12 months ago by andrew_b

  • Votes for changeset changed from andrew_b to committed-master
  • Branch state changed from approved to merged

comment:15 Changed 12 months ago by andrew_b

Cannot close this ticket because of internal error -- this ticket is self-blocked. The "Blocking:" field is empty but blocking info is in Trac database and I'm unable to remove it from there.

comment:16 Changed 11 months ago by zaytsev

Ticket #4449 has been marked as a duplicate of this ticket.

comment:17 follow-up: ↓ 19 Changed 11 months ago by zaytsev

  • Status changed from accepted to testing
  • Resolution set to fixed

Fixed by editing the database directly.

comment:18 Changed 11 months ago by andrew_b

  • Status changed from testing to closed

comment:19 in reply to: ↑ 17 Changed 11 months ago by andrew_b

Replying to zaytsev:

Fixed by editing the database directly.

Thanks!

Note: See TracTickets for help on using tickets.