Ticket #4403 (closed defect: duplicate)

Opened 22 months ago

Last modified 22 months ago

opening zip archive with pdf as a first file fails

Reported by: durdin Owned by:
Priority: major Milestone:
Component: mc-core Version: 4.8.28
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

I've first faced it with Intel NUC 10 BIOS zip file (either UEFI or Recorvery version) from https://www.intel.com/content/www/us/en/download/19485/bios-update-fncml357.html, but as tested it happens with any zip file which has first entry as a PDF.

When you try to open it in MC (by hitting Enter on it) and when in X-session it opens the system archiver, hitting "enter" on the file in base terminal without X-session attempts to parse the zip via some console pdf viewer but obviously fails with:

Syntax Warning: May not be a PDF file (continuing anyway)
Syntax Error: Couldn't find trailer dictionary
Syntax Error: Couldn't find trailer dictionary
Syntax Error: Couldn't read xref table

Trying to view the zip via the "F3" results in an error: Syntax Warning: May not be a PDF file (continuing anyway), but nothing happens.

MC version (running on debian):

$ LANG=C mc -V
GNU Midnight Commander 4.8.28
Built with GLib 2.72.0
Built with S-Lang 2.3.2 with terminfo database
Built with libssh2 1.10.0
With builtin Editor and Aspell support
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
With ext2fs attributes support
Virtual File Systems:
 cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, sftpfs, fish
Data types:
 char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

$ LANG=C mc -F
[System data]
    Config directory: /etc/mc/
    Data directory:   /usr/share/mc/
    File extension handlers: /usr/lib/mc/ext.d/
    VFS plugins and scripts: /usr/lib/mc/
	extfs.d:        /usr/lib/mc/extfs.d/
	fish:           /usr/lib/mc/fish/

$ mc --configure-options
 '--build=x86_64-linux-gnu' '--prefix=/usr' '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--sysconfdir=/etc' '--localstatedir=/var' '--disable-option-checking' '--libdir=${prefix}/lib/x86_64-linux-gnu' '--runstatedir=/run' '--disable-maintainer-mode' '--disable-dependency-tracking' 'AWK=awk' 'X11_WWW=x-www-browser' '--libexecdir=/usr/lib' '--with-x' '--with-screen=slang' '--disable-rpath' '--disable-static' '--disable-silent-rules' '--enable-aspell' '--enable-vfs-sftp' '--enable-vfs-undelfs' '--enable-tests' 'build_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2 -ffile-prefix-map=/build/mc-rb7yno/mc-4.8.28=. -fstack-protector-strong -Wformat -Werror=format-security' 'LDFLAGS=-Wl,-z,relro -Wl,-z,now -Wl,--as-needed' 'CPPFLAGS=-Wdate-time -D_FORTIFY_SOURCE=2'

Archive used:

$ zipinfo FNCML357.0057.UEFI.zip 
Archive:  FNCML357.0057.UEFI.zip
Zip file size: 11594357 bytes, number of entries: 3
-rw-a--     2.0 fat   739251 bx defX 21-Jan-29 14:18 iFlashV-User-Guide-V3.0.pdf
-rw-a--     2.0 fat   418448 bx defX 22-Mar-31 01:32 iFlashVEfi64.efi
-rw-a--     2.0 fat 20971520 bx defX 22-May-20 03:46 FN0057.cap
3 files, 22129219 bytes uncompressed, 11593893 bytes compressed:  47.6%

Change History

comment:1 Changed 22 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #4368.

Note: See TracTickets for help on using tickets.