Ticket #4372 (closed defect: fixed)

Opened 7 months ago

Last modified 6 months ago

fish commands don't work after window resize

Reported by: congest Owned by: andrew_b
Priority: minor Milestone: 4.8.29
Component: mc-core Version: master
Keywords: fish Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description

To reproduce:

start mc (with fish as your shell)
resize mc window
type any command in the command prompt, for example, "ls"
nothing happens
type the same command again
it works now, the second time

Someone made a quick hack patch in this other ticket about an unrelated issue https://midnight-commander.org/ticket/4188 but it looks like the bug never got fixed.

Attachments

fish_resize_bug.patch (1.8 KB) - added by congest 7 months ago.

Change History

Changed 7 months ago by congest

comment:1 Changed 7 months ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b
  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.29

Thanks!

Applied with trivial modifications.

Branch: 4372_fish_resize
changeset:4667618e68425df66f790be7df868c3c687c631c

comment:2 Changed 7 months ago by andrew_b

@congest, since you're a fish user, can I ask you some questions about fish-related bugs.

  1. What do you think about #4188?
  2. What do you think about #4258? I think, at least a pty buffer is too small.

comment:3 Changed 6 months ago by andrew_b

  • Votes for changeset set to andrew_b
  • Branch state changed from on review to approved

comment:4 Changed 6 months ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:5 Changed 6 months ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.