Ticket #4358 (closed defect: fixed)

Opened 3 months ago

Last modified 4 weeks ago

Variable redeclared in filevercmp_test5

Reported by: ats Owned by: andrew_b
Priority: minor Milestone: 4.8.29
Component: tests Version: 4.8.28
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

In mc-4.8.28, the test filevercmp_test5 in tests/lib/strutil/filevercmp.c declares:

size_t _i;

However, the name _i is also used inside check's START_TEST macro, so GCC 11.2 complains:

filevercmp.c: In function ‘filevercmp_test5_fn’:
filevercmp.c:356:12: error: ‘_i’ redeclared as different kind of symbol

I've fixed this in the attached patch by renaming _i and _j, but you may prefer a different new name...

Attachments

checki.diff (1.3 KB) - added by ats 3 months ago.
Patch: rename _i/_j to ii/jj

Change History

Changed 3 months ago by ats

Patch: rename _i/_j to ii/jj

comment:1 Changed 3 months ago by andrew_b

  • Component changed from mc-core to tests

comment:2 Changed 3 months ago by andrew_b

  • Owner set to andrew_b
  • Status changed from new to accepted
  • Blocked By 4357 added
  • Milestone changed from Future Releases to 4.8.29

Thanks!
Applied in 4357_cleanup branch.

Last edited 3 months ago by andrew_b (previous) (diff)

comment:3 Changed 3 months ago by andrew_b

Ticket #4359 has been marked as a duplicate of this ticket.

comment:4 Changed 3 months ago by andrew_b

Ticket #4366 has been marked as a duplicate of this ticket.

comment:5 Changed 4 weeks ago by andrew_b

  • Blocked By 4357 removed

comment:6 Changed 4 weeks ago by andrew_b

  • Status changed from accepted to testing
  • Resolution set to fixed

comment:7 Changed 4 weeks ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.