Ticket #4290 (closed enhancement: duplicate)

Opened 8 months ago

Last modified 8 months ago

Show directory sizes doesn't handle hard links

Reported by: birdie Owned by:
Priority: minor Milestone:
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

It would be great if this command took hard links into consideration.

Change History

comment:1 Changed 8 months ago by andrew_b

Are you sure?
#3647

comment:2 Changed 8 months ago by birdie

mkdir 1 && cd 1
dd if=/dev/zero of=test bs=1M count=1
ln test test2
ln test test3
ln test test4
du .
1024	.

mc shows 4194304 bytes

comment:3 Changed 8 months ago by zaytsev

  • Status changed from new to closed
  • Resolution set to duplicate

Closed as duplicate of #3647.

comment:4 Changed 8 months ago by zaytsev

  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.