Ticket #4237 (closed defect: duplicate)

Opened 16 months ago

Last modified 15 months ago

Files with more than one hard link are not highlighted

Reported by: birdie Owned by:
Priority: minor Milestone:
Component: mc-core Version: 4.8.26
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Consider this listing:

DOOMx64 2016-10-01 17-47-37-81 non stop 10-40-00.webp
DXMD 2017-02-01 00-40-09-93.webp
DXMD 2017-02-03 23-54-49-81.webp
DXMD 2017-02-07 19-24-13-16.webp
DXMD 2017-02-10 03-30-03-35.webp
DXMD 2017-02-10 22-34-39-24.webp
DXMD 2017-02-11 03-03-35-61.webp
MMH7Game-Win64-Shipping 2015-10-01 22-30-40-52.webp
MMH7Game-Win64-Shipping 2015-10-15 23-56-34-96.webp
MMH7Game-Win64-Shipping 2015-10-15 23-59-23-87.webp
MMH7Game-Win64-Shipping 2015-10-16 00-00-26-78.webp
MMH7Game-Win64-Shipping 2015-10-16 00-05-06-77.webp
MMH7Game-Win64-Shipping 2015-10-16 00-07-53-69.webp
MMH7Game-Win64-Shipping 2015-10-16 01-22-08-44.webp
MMH7Game-Win64-Shipping 2015-10-16 01-22-15-98.webp
MMH7Game-Win64-Shipping 2015-10-16 01-26-08-43.webp
MMH7Game-Win64-Shipping 2015-10-16 02-25-24-29.webp
MMH7Game-Win64-Shipping 2015-10-16 15-19-40-49.webp
MMH7Game-Win64-Shipping 2015-10-17 05-50-10-28.webp
solitaire 2017-06-27 00-19-43-96.webp
solitaire 2017-11-03 19-36-46-23.webp
solitaire 2017-11-03 19-36-50-81.webp
solitaire 2017-11-03 19-37-46-29.webp
solitaire 2017-11-03 19-37-55-94.webp
solitaire 2017-11-03 19-38-31-96.webp
solitaire 2017-11-03 19-38-39-52.webp
solitaire 2017-11-03 19-39-21-23.webp
solitaire 2017-11-03 19-39-24-49.webp
solitaire 2017-11-03 19-39-39-11.webp
TheDivision 2016-12-17 06-07-10-50.webp
TheDivision 2017-01-17 22-33-53-42.webp
TheDivision 2017-01-21 07-39-48-73.webp
TheDivision 2017-01-23 00-23-14-65.webp
TheDivision 2017-03-03 19-07-52-49.webp

And this is how it's colored/highlighted (see the attached file)

Attachments

media2.png (7.2 KB) - added by birdie 16 months ago.
fuse-vs-native.png (20.8 KB) - added by birdie 16 months ago.

Change History

Changed 16 months ago by birdie

comment:1 Changed 16 months ago by andrew_b

Is there a space char at the end of non-colored file name?

Last edited 16 months ago by andrew_b (previous) (diff)

comment:2 Changed 16 months ago by birdie

These files are properly highlighted when they on ext4/vfat filesystems (both native) however the bug occurs when they are copied to an ntfs-3g (fuse) filesystem.

There are no invisible characters at the end of their names.

You can create them:

cat | while read fname; do touch "$fname"; done

Changed 16 months ago by birdie

comment:3 follow-up: ↓ 4 Changed 16 months ago by ossi

i've noticed that highlighting is broken when files have hardlinks. maybe that's related.

comment:4 in reply to: ↑ 3 ; follow-up: ↓ 5 Changed 16 months ago by birdie

Replying to ossi:

i've noticed that highlighting is broken when files have hardlinks. maybe that's related.

That actually might be the case but the files in question don't have any hard links but maybe FUSE works differently.

comment:5 in reply to: ↑ 4 Changed 16 months ago by andrew_b

Replying to birdie:

Replying to ossi:

i've noticed that highlighting is broken when files have hardlinks. maybe that's related.

#3234, #3375

That actually might be the case but the files in question don't have any hard links but maybe FUSE works differently.

Please show the output of ls -l on both file systems.

comment:6 Changed 15 months ago by birdie

That's actually the case.

Files with two hard links are NOT highlighted - that's obviously a bug in NTFS-3G but MC should work regardless.

comment:7 Changed 15 months ago by birdie

  • Summary changed from Not all media files are highlighted/colored as such to Files with more than one hard link are not highlighted

comment:8 Changed 15 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #3234.

Note: See TracTickets for help on using tickets.