Ticket #4236 (closed defect: duplicate)

Opened 16 months ago

Last modified 16 months ago

FreeBSD v13 - strange crash

Reported by: ahhyes Owned by:
Priority: major Milestone:
Component: mc-core Version: 4.8.26
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Hi,

I have a strange problem occurring after upgrading to FreeBSD version 13 where the application crashes if I attempt to start it as the root user. If I try the application as a standard user account on the said system, there are no crashes.

To make the issue even more crazy, I went and tested the application on another box I had upgraded to v13 and the program does not crash as root there. This means the issue is specific to one system, but I have no idea what the cause is.

I recompiled the application from ports to include debugging information and ran it under gdb and it produced a backtrace. I'm not able to paste it here because the crash completely screws up my terminal to the point where i can no longer select text to copy, lol.

A screenshot of the backtrace can be seen here:

https://prnt.sc/11sxguw

I suspect something in root's environment is triggering the crash but no idea what. To try and eliminate possibilities, I moved all the related "." hidden files and folders for root out to another dir temporarily in case one of the shell preference files was setting something that was upsetting the program, it made no difference.

Linking against either slang or ncurses makes no difference.

Output of mc -V:

GNU Midnight Commander 4.8.26
Built with GLib 2.66.7
Built with ncurses 6.2
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm
With support for X11 events
With internationalization support
With multiple codepages support
With ext2fs attributes support
Virtual File Systems:
 cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, fish
Data types:
 char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Attachments

Screenshot_20210421_223040.png (169.9 KB) - added by ahhyes 16 months ago.
gdb backtrace

Change History

Changed 16 months ago by ahhyes

gdb backtrace

comment:1 Changed 16 months ago by ossi

completely screws up my terminal to the point where i can no longer select text to copy

sure? to select text for x11-native pasting you always have to press shift while selecting when you're in mc, as it instructs the terminal to let it handle the mouse. after mc crashes, you of course see the raw escape sequences. you can restore normality with the 'reset' command.

comment:2 Changed 16 months ago by andrew_b

  • Status changed from new to closed
  • Version changed from master to 4.8.26
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #4213.

Note: See TracTickets for help on using tickets.