Ticket #4235 (closed defect: fixed)

Opened 3 years ago

Last modified 16 months ago

file search with relativ ignore_dir working weird

Reported by: dextarr Owned by: andrew_b
Priority: major Milestone: 4.8.30
Component: mc-core Version: master
Keywords: Cc:
Blocked By: Blocking:
Branch state: merged Votes for changeset: committed-master

Description (last modified by andrew_b) (diff)

up-to-date-kde-neon$ mc -V
GNU Midnight Commander 4.8.24
Built with GLib 2.63.3
Using the S-Lang library with terminfo database
With builtin Editor and Aspell support
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, sftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Dear Developers,

I have a problem with the file search (M-?) feature.
Lets assume I have the following directory structure:

/tmp/base1/
/tmp/base1/.secret/
/tmp/base1/.secret/config2
/tmp/base1/.secret/.secret/
/tmp/base1/.secret/.secret/config3
/tmp/base1/config1

I want to search for files named 'config*' using following options:

start at = .
ignore list = .secret
find recursive = on
file name = config*

if I'm standing in /tmp/base1/ the result is ./config1, which is what I expect as anything in .secret (and _relative_ below) would be ignored.

if I'm standing in /tmp/base1/.secret/ there is nothing found :(

I would expect the result would be the ./config2 as the ignore list contains a relative ignore (.secret) and only config3 would still get ignored.

Looks like the search gets ignored just because there exists a path component .secret above(!) where I'm standing at, which I find confusing (wrong?).

Turning off ignore_list is not an option because then I would find ./config2 but also .secret/config3 and potentially any .secret/* */config*

I cound not find an ignore_list/option combination where the ignore gets applied really _below_ where I'm standing at...

Is this the expected behavior?

thanks for checking out (and hopefully fixing)!

Change History

comment:1 Changed 23 months ago by andrew_b

  • Component changed from mc-search to mc-core
  • Description modified (diff)

comment:2 Changed 16 months ago by andrew_b

  • Status changed from new to accepted
  • Owner set to andrew_b
  • Branch state changed from no branch to on review
  • Milestone changed from Future Releases to 4.8.30

Branch: 4235_find_relative_ignore_dir
changeset:bde254c137a797d2707339f32b4b4c81ace5800a

comment:3 Changed 16 months ago by andrew_b

  • Votes for changeset set to andrew_b
  • Branch state changed from on review to approved

comment:4 Changed 16 months ago by andrew_b

  • Status changed from accepted to testing
  • Votes for changeset changed from andrew_b to committed-master
  • Resolution set to fixed
  • Branch state changed from approved to merged

comment:5 Changed 16 months ago by andrew_b

  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.