Ticket #4227 (closed enhancement: duplicate)

Opened 5 months ago

Last modified 5 months ago

copy(move) via ssh [fish] - prevent usage of tmp

Reported by: schnedan Owned by:
Priority: major Milestone:
Component: mc-vfs Version: master
Keywords: ssh fish /tmp Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

I often use mc for convinient copy/move of files via ssh.

There seems to be some problems associated with the usage of /tmp by mc
when a file is bigger than the space available in /tmp the operation is not prevented. mc will copy the file which is about to be copied/moved to "/tmp/mc-username" first and fail as soon as /tmp is full.

when mc crashes or needs to be killed (no further response), whatever what it left in "/tmp/mc-username" is not removed

So my suggestion is:

  • at least optionally it should be possible to not utilize /tmp but to copy files directly (maybe warn the user to not change/remove the file)
  • check size of tmp prior of starting an action – and e.g. if the file which is about to be copied/moved, is larger than the available space in /tmp mc should either abort the operation or not using /tmp
  • clear "/tmp/mc-username" when mc is started, so leftovers from an privious instance are removed (add an instance ID to the filenames, so you can query if there is another instance which owns the file)

Change History

comment:1 Changed 5 months ago by schnedan

sorry, the ticket was crated multiple times as there was no response of the webpage and I pressed the button several times...

comment:2 Changed 5 months ago by andrew_b

  • Status changed from new to closed
  • Component changed from mc-core to mc-vfs
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #77.
Sorry too but why not just use search and find #77 before create tickets?

comment:3 Changed 5 months ago by schnedan

  • first: I did search, but I haven't found that
  • second: my suggestions go beyond what the other ticket states (so you actually read mine?)
Note: See TracTickets for help on using tickets.