Ticket #4208 (closed defect: duplicate)

Opened 15 months ago

Last modified 15 months ago

Cannot open/view JAR file after update to 4.8.26

Reported by: mfrydl Owned by:
Priority: major Milestone:
Component: mc-vfs Version: 4.8.26
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Hello,

after upgrading from 4.8.25 to 4.8.26, JAR files can no longer be opened or viewed. When I press Enter on JAR file, nothing happens. When I press F3 (view), dialog with message appears: "Cannot open "/tmp/commons-cli-1.4.jar" in parse mode. No such file or directory (2)". When I change extension of file to zip, it works fine so it is probably caused by some configuration. In version 4.8.25, it worked fine. I have mc from Fedora 33, but according to SRPM, it's not patched.

LC_MESSAGES=C mc -V

GNU Midnight Commander unknown
Built with GLib 2.66.4
Built with S-Lang 2.3.2 with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With internationalization support
With multiple codepages support
With ext2fs attributes support
Virtual File Systems:

cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, fish, smbfs

Data types:

char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

LC_MESSAGES=C mc -F

Home directory: /home/martin.frydl
Profile root directory: /home/martin.frydl

[System data]

Config directory: /etc/mc/
Data directory: /usr/share/mc/
File extension handlers: /usr/libexec/mc/ext.d/
VFS plugins and scripts: /usr/libexec/mc/

extfs.d: /usr/libexec/mc/extfs.d/
fish: /usr/libexec/mc/fish/

[User data]

Config directory: /home/martin.frydl/.config/mc/
Data directory: /home/martin.frydl/.local/share/mc/

skins: /home/martin.frydl/.local/share/mc/skins/
extfs.d: /home/martin.frydl/.local/share/mc/extfs.d/
fish: /home/martin.frydl/.local/share/mc/fish/
mcedit macros: /home/martin.frydl/.local/share/mc/mc.macros
mcedit external macros: /home/martin.frydl/.local/share/mc/mcedit/macros.d/macro.*

Cache directory: /home/martin.frydl/.cache/mc/

mc --configure-options

'--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--program-prefix=' '--disable-dependency-tracking' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib64' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/var/lib' '--mandir=/usr/share/man' '--infodir=/usr/share/info' 'PYTHON=/usr/bin/python3' '--disable-rpath' '--enable-charset' '--enable-largefile' '--enable-vfs-cpio' '--enable-vfs-extfs' '--enable-vfs-fish' '--enable-vfs-ftp' '--enable-vfs-sfs' '--enable-vfs-sftp' '--enable-vfs-smb' '--enable-vfs-tar' '--with-x' '--with-gpm-mouse' '--with-screen=slang' 'build_alias=x86_64-redhat-linux-gnu' 'host_alias=x86_64-redhat-linux-gnu' 'CC=gcc' 'CFLAGS=-O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection' 'LDFLAGS=-Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld ' 'LT_SYS_LIBRARY_PATH=/usr/lib64:' 'PKG_CONFIG_PATH=:/usr/lib64/pkgconfig:/usr/share/pkgconfig'

Change History

comment:1 Changed 15 months ago by mfrydl

Definitely duplicate of #4180. Looks like 4.8.27 should fix it.

comment:2 Changed 15 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #4180.

Note: See TracTickets for help on using tickets.