Ticket #4197 (closed enhancement: duplicate)

Opened 12 months ago

Last modified 12 months ago

mc-4.8.26: shell link makes fish eat up all disk space

Reported by: cederom Owned by:
Priority: major Milestone:
Component: mc-vfs Version: master
Keywords: scp fish tmp cache Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Hello world :-)

I noticed that mc uses fish to send files over scp (aka shell link). When files are large and there are lots of files all fish cache that resides in /tmp/mc-user is not cleared after single file is sent. This results in excessive disk usage and sometimes even eats up all of the disk space (in my case mc took over 40GB of tmp space).

I would like to propose a change that fish cache is cleared for each sent file, so it does not unnecessarily consume disk space.

Thanks :-)
Tomek

Change History

comment:1 Changed 12 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone 4.8.27 deleted

Closed as duplicate of #77.

Note: See TracTickets for help on using tickets.