Ticket #4143 (closed defect: invalid)

Opened 11 months ago

Last modified 11 months ago

mc inside screen with incorrect colors

Reported by: cheese Owned by:
Priority: major Milestone:
Component: mc-tty Version: 4.8.24
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

hi

if i use mc inside of screen i get "weird" images. it seems that mc does not color to the end of the line, but only until it reaches the last character per line.

viewer/editor behave the same.
outside of screen everything looks OK.

installed version: mc-4.8.24-4.fc32.x86_64 under fedora 32

attached are three screenshot:
outside_screen.png which is OK
inside_mc.png which is NOT OK. Mind the top line.
inside_screen_viewer.png which is not OK. from inside the viewer.

Attachments

outside_screen.png (119.1 KB) - added by cheese 11 months ago.
inside_screen_viewer.png (113.5 KB) - added by cheese 11 months ago.
inside_mc.png (119.9 KB) - added by cheese 11 months ago.

Change History

Changed 11 months ago by cheese

Changed 11 months ago by cheese

Changed 11 months ago by cheese

comment:1 Changed 11 months ago by cheese

  • Version changed from master to 4.8.24

comment:2 Changed 11 months ago by angel_il

what about TERM?
echo $TERM

try: export TERM=screen-256color
or export TERM=xterm
inside screen session

comment:3 Changed 11 months ago by cheese

inside and outside of screen i have

[cheese@hp SPECS]$ echo $TERM
xterm which leads to the artifacts.

will create some screenshots with all combinations later today.

comment:4 Changed 11 months ago by zaytsev

Ticket #4148 has been marked as a duplicate of this ticket.

comment:5 Changed 11 months ago by zaytsev

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=854414

Bottom line:

A proper workaround might be to set screen-256color from screenrc

comment:6 Changed 11 months ago by cheese

thanks for sending me in the right direction. i had a hard setting of TERM=xterm in my bashrc, which broke inside screen. the reason for that crude setting was that 256-color did not match the "correct" colors in mc. eg.: blue in 256-color was not the same blue. seems to fixed in fresher fedoras.

comment:7 Changed 11 months ago by cheese

as this was obviously my own fault: can be closed.

comment:8 Changed 11 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to invalid
  • Component changed from mc-core to mc-tty
  • Milestone Future Releases deleted
Note: See TracTickets for help on using tickets.