Ticket #4118 (closed defect: duplicate)

Opened 13 months ago

Last modified 12 months ago

Midnight Commander truncate filenames when browse archives

Reported by: ieleja Owned by:
Priority: major Milestone:
Component: mc-vfs Version: master
Keywords: truncate filenames ir archives Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description (last modified by andrew_b) (diff)

it is some files from trusted source with this effect:
https://releases.wikimedia.org/mediawiki/1.35/mediawiki-1.35.0.tar.gz

if browse archive with entering into with MC, files shows with truncated filenames if path name is longer than same value (77 characters?), if we copy, file also comes with truncated filename, for example:
./mediawiki-1.35.0/skins/Vector/tests/phpunit/integration/FeatureManagement/Requirements/LatestSkinVersionRequirementTest.php
comes as
./mediawiki-1.35.0/skins/Vector/tests/phpunit/integration/FeatureManagement/Requirements/LatestSkinVer

this brokes everything

==========

Debian 10 and Ubuntu 18.04
error with native distributions MC versions, then install 4.8.25 binaries from:
http://www.tataranovich.com/

# LC_MESSAGES=C mc -F

Home directory: /root
Profile root directory: /root

[System data]
    Config directory: /etc/mc/
    Data directory:   /usr/share/mc/
    File extension handlers: /usr/lib/mc/ext.d/
    VFS plugins and scripts: /usr/lib/mc/
	extfs.d:        /usr/lib/mc/extfs.d/
	fish:           /usr/lib/mc/fish/

[User data]
    Config directory: /root/.config/mc/
    Data directory:   /root/.local/share/mc/
	skins:          /root/.local/share/mc/skins/
	extfs.d:        /root/.local/share/mc/extfs.d/
	fish:           /root/.local/share/mc/fish/
	mcedit macros:  /root/.local/share/mc/mc.macros
	mcedit external macros: /root/.local/share/mc/mcedit/macros.d/macro.*
    Cache directory:  /root/.cache/mc/

# mc --configure-options
 '--build=x86_64-linux-gnu' '--prefix=/usr' '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--sysconfdir=/etc' '--localstatedir=/var' '--libexecdir=/usr/lib' '--srcdir=.' '--disable-maintainer-mode' '--disable-dependency-tracking' '--disable-silent-rules' '--with-x' '--with-screen=slang' '--enable-aspell' '--disable-rpath' '--disable-static' 'build_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2 -fdebug-prefix-map=/build/mc-4.8.25=. -fstack-protector-strong -Wformat -Werror=format-security' 'LDFLAGS=-Wl,-Bsymbolic-functions -Wl,-z,relro' 'CPPFLAGS=-Wdate-time -D_FORTIFY_SOURCE=2'

Attachments

2020-09-29_04-14.png (34.1 KB) - added by ieleja 13 months ago.
described files in MC

Change History

Changed 13 months ago by ieleja

described files in MC

comment:1 Changed 13 months ago by andrew_b

I just can't believe that you ignored search and created new ticket instead of find #4116 and #2201.

comment:2 Changed 13 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Component changed from mc-core to mc-vfs
  • Milestone Future Releases deleted

Closed as duplicate of #2201.

comment:3 Changed 12 months ago by andrew_b

  • Description modified (diff)
Note: See TracTickets for help on using tickets.