Ticket #4084 (closed task: duplicate)

Opened 2 years ago

Last modified 19 months ago

Need help to learn keys: Home, End

Reported by: blueice_haller Owned by:
Priority: major Milestone:
Component: mc-tty Version: 4.8.21
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Hi,
I connect from Windows using PuTTY with an embedded Linux (mips CPU).
In the Terminal and Vi Editor the Home and End keys are working.

I'm unable to learn the keys in Midnight Commander (mc and mcedit).

When I try to learn the keys nothing happens.

Thank you in advance.

root@xpeedlx3:~# mc -V
GNU Midnight Commander 4.8.21
Built with GLib 2.58.0
Using the ncurses library
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, fish
Data types: char: 8; int: 32; long: 32; void *: 32; size_t: 32; off_t: 64;

Change History

comment:1 Changed 2 years ago by blueice_haller

When using Cygwin and connecting to the target then Home and End keys are working with mc and mcedit.

Last edited 2 years ago by blueice_haller (previous) (diff)

comment:2 Changed 2 years ago by zaytsev

  • Milestone changed from 4.8.25 to 4.8.26

comment:3 Changed 20 months ago by andrew_b

  • Component changed from mc-core to mc-tty
  • Milestone changed from 4.8.26 to Future Releases

comment:4 Changed 19 months ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #2837.

Note: See TracTickets for help on using tickets.