Ticket #4044 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

mc halts during start-up when there's no internet connection

Reported by: szotsaki Owned by:
Priority: major Milestone:
Component: mc-vfs Version: 4.8.23
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

If you have a bad, non-working but active, or non-existent internet connection, mc halts during startup for several seconds (sometimes minutes).

With strace I could get the following when the halt happens:

futex(0x7fcccbd49324, FUTEX_WAKE_PRIVATE, 2147483647) = 0
openat(AT_FDCWD, "/etc/resolv.conf", O_RDONLY|O_CLOEXEC) = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=688, ...}) = 0
read(3, "### /etc/resolv.conf is a symlin"..., 4096) = 688
read(3, "", 4096)                       = 0
close(3)                                = 0
socket(AF_UNIX, SOCK_STREAM|SOCK_CLOEXEC|SOCK_NONBLOCK, 0) = 3
connect(3, {sa_family=AF_UNIX, sun_path="/var/run/nscd/socket"}, 110) = 0
sendto(3, "\2\0\0\0\r\0\0\0\6\0\0\0hosts\0", 18, MSG_NOSIGNAL, NULL, 0) = 18
poll([{fd=3, events=POLLIN|POLLERR|POLLHUP}], 1, 5000) = 1 ([{fd=3, revents=POLLIN|POLLHUP}])
recvmsg(3, {msg_name=NULL, msg_namelen=0, msg_iov=[{iov_base="hosts\0", iov_len=6}, {iov_base="\310O\3\0\0\0\0\0", iov_len=8}], msg_iovlen=2, msg_control=[{cmsg_len=20, cmsg_level=SOL_SOCKET, cmsg_type=SCM_RIGHTS, cmsg_data=[4]}], msg_controllen=20, msg_flags=MSG_CMSG_CLOEXEC}, MSG_CMSG_CLOEXEC) = 14
mmap(NULL, 217032, PROT_READ, MAP_SHARED, 4, 0) = 0x7fcccaf32000
close(4)                                = 0
close(3)                                = 0
socket(AF_UNIX, SOCK_STREAM|SOCK_CLOEXEC|SOCK_NONBLOCK, 0) = 3
connect(3, {sa_family=AF_UNIX, sun_path="/var/run/nscd/socket"}, 110) = 0
sendto(3, "\2\0\0\0\4\0\0\0\r\0\0\0linux-laptop\0", 25, MSG_NOSIGNAL, NULL, 0) = 25
poll([{fd=3, events=POLLIN|POLLERR|POLLHUP}], 1, 5000

The same trace is reproducible.

GNU Midnight Commander 4.8.23
Built with GLib 2.62.2
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ftpfs, sftpfs, smbfs
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;

Change History

comment:1 Changed 3 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Component changed from mc-core to mc-vfs
  • Milestone Future Releases deleted

Closed as duplicate of #40.

Note: See TracTickets for help on using tickets.