Ticket #3951 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

File timestamps are not preserved when copying files into ZIP archives

Reported by: mcoq Owned by:
Priority: minor Milestone:
Component: mc-vfs Version: 4.8.21
Keywords: Cc:
Blocked By: Blocking:
Branch state: no branch Votes for changeset:

Description

Timestamps atime/mtime are not preserved over extfs.d/uzip copyin action

However, I suppose any other extfs scripts may produce the same behaviour, as a temporary copy of the source file is created in the /tmp/mc-<username> folder, and that file is inserted into the target extfs instance.

The timestamps of the temporary file reflect the time of the copyin action, so the target file in the extfs instance will also differ from the original one.


osb@u18box:/tmp$ LC_MESSAGES=C mc -V
GNU Midnight Commander 4.8.21
Built with GLib 2.56.1
Using the S-Lang library with terminfo database
With builtin Editor
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
With internationalization support
With multiple codepages support
Virtual File Systems: cpiofs, tarfs, sfs, extfs, ext2undelfs, ftpfs, sftpfs, fish
Data types: char: 8; int: 32; long: 64; void *: 64; size_t: 64; off_t: 64;


osb@u18box:/tmp$ LC_MESSAGES=C mc -F
Home directory: /home/osb
Profile root directory: /home/osb

[System data]

Config directory: /etc/mc/
Data directory: /usr/share/mc/
File extension handlers: /usr/lib/mc/ext.d/
VFS plugins and scripts: /usr/lib/mc/

extfs.d: /usr/lib/mc/extfs.d/
fish: /usr/lib/mc/fish/

[User data]

Config directory: /home/osb/.config/mc/
Data directory: /home/osb/.local/share/mc/

skins: /home/osb/.local/share/mc/skins/
extfs.d: /home/osb/.local/share/mc/extfs.d/
fish: /home/osb/.local/share/mc/fish/
mcedit macros: /home/osb/.local/share/mc/mc.macros
mcedit external macros: /home/osb/.local/share/mc/mcedit/macros.d/macro.*

Cache directory: /home/osb/.cache/mc/


osb@u18box:/tmp$ mc --configure-options

'--build=x86_64-linux-gnu' '--prefix=/usr' '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--sysconfdir=/etc' '--localstatedir=/var' '--libdir=${prefix}/lib/x86_64-linux-gnu' '--libexecdir=${prefix}/lib/x86_64-linux-gnu' '--runstatedir=/run' '--disable-maintainer-mode' '--disable-dependency-tracking' 'AWK=awk' 'X11_WWW=x-www-browser' '--libexecdir=/usr/lib' '--with-x' '--with-screen=slang' '--disable-rpath' '--disable-static' '--disable-silent-rules' '--enable-aspell' '--enable-vfs-sftp' '--enable-vfs-undelfs' '--enable-tests' 'build_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2 -fdebug-prefix-map=/build/mc-ztznSF/mc-4.8.21=. -fstack-protector-strong -Wformat -Werror=format-security' 'LDFLAGS=-Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-z,now -Wl,--as-needed' 'CPPFLAGS=-Wdate-time -D_FORTIFY_SOURCE=2'

Change History

comment:1 Changed 3 years ago by mcoq

Opposite to #3916

comment:2 Changed 3 years ago by birdie

This affects pretty much all archivers that MC supports including RAR/7z/etc.

comment:3 Changed 3 years ago by andrew_b

  • Status changed from new to closed
  • Resolution set to duplicate
  • Milestone Future Releases deleted

Closed as duplicate of #3650.

Note: See TracTickets for help on using tickets.