Ticket #394 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

broken history feature

Reported by: bomj Owned by: andrew_b
Priority: major Milestone: 4.7.0-pre1
Component: mc-core Version: master
Keywords: commited-master Cc:
Blocked By: Blocking:
Branch state: Votes for changeset:

Description (last modified by andrew_b) (diff)

broken history feature

Attachments

history_ (1 bytes) - added by iNode 10 years ago.
content of file actually doesn't matter

Change History

comment:1 Changed 10 years ago by bomj

  • Summary changed from broken history feature in "FTP to machine" text line in mc-20090514 from slackware to broken history feature in "FTP/Shell/SMB link to machine" text line in mc-20090514 from slackware

comment:2 Changed 10 years ago by bomj

  • Summary changed from broken history feature in "FTP/Shell/SMB link to machine" text line in mc-20090514 from slackware to broken history feature in text input lines in mc-20090514 from slackware

In "FTP/Shell/SMB link to machine", user menu @ "Do something on the current file"
also maybe anythere else
can't find history feature, alt+p key combination does not work.

comment:3 Changed 10 years ago by bomj

  • Summary changed from broken history feature in text input lines in mc-20090514 from slackware to broken history feature - solved by rm ~/.mc/history

comment:4 Changed 10 years ago by andrew_b

  • Blocked By 391 added

comment:5 Changed 10 years ago by slavazanko

  • Blocked By 391 removed

(In #391) created branch 291_broken_history (parent: master)

Initial commit: changeset: 8a3e1a8f5ba05cd5873903ec90ec81a1cf90f338

comment:6 Changed 10 years ago by slavazanko

  • Blocked By 391 added

comment:7 Changed 10 years ago by slavazanko

  • Blocked By 391 removed

comment:8 Changed 10 years ago by slavazanko

  • Status changed from new to closed
  • Resolution set to worksforme

To ticketstarter: as I understood, you was have broken ~/.mc/history file.
This ticket closed as "worksforme". If this don't right - reopen, please.

comment:9 follow-up: ↓ 10 Changed 10 years ago by iNode

  • Status changed from closed to reopened
  • Resolution worksforme deleted
  • Summary changed from broken history feature - solved by rm ~/.mc/history to broken history feature

In file select dialog (M-+) history also don't work.

(~/.mc/history was removed before start mc)

comment:10 in reply to: ↑ 9 Changed 10 years ago by andrew_b

  • Owner set to andrew_b
  • Keywords review added
  • Version set to master
  • Status changed from reopened to accepted
  • Milestone set to 4.7.0-pre1

Replying to iNode:

In file select dialog (M-+) history also don't work.
(~/.mc/history was removed before start mc)

It'a bug of mcconfig module -- it doesn't handle the empty ~/.mc/history file correctly.

The 394_history_file branch is created. Parent branch: master.
changeset:920c83f6f08db26adb64e33b305b9b6a4b4a57ec

comment:11 Changed 10 years ago by iNode

History file attached.

Glib Version: 2.20.1-0ubuntu2

comment:12 follow-up: ↓ 13 Changed 10 years ago by iNode

Yes, empty file now handle properly.

It seems to be permission problems in this case: ~/.mc/history file owner isn't actual current user, and mc can't hadnle it correctly. To reproduce that use case just run sudo mc and try
to select group of files, config owner will be changed to root.

Changed 10 years ago by iNode

content of file actually doesn't matter

comment:13 in reply to: ↑ 12 Changed 10 years ago by andrew_b

Replying to iNode:

It seems to be permission problems in this case: ~/.mc/history file owner isn't actual current user, and mc can't hadnle it correctly. To reproduce that use case just run sudo mc and try
to select group of files, config owner will be changed to root.

Yes. By default, the always_set_home flag is not set and root under sudo has not root's $HOME. IMHO it is wrong. Correct your sudo configuration.

comment:14 Changed 10 years ago by iNode

Ok, that's correct.

But we should show warnings when config format or permissions is invalid.

comment:15 Changed 10 years ago by angel_il

  • Milestone changed from 4.7.0-pre1 to 4.7

comment:16 Changed 10 years ago by andrew_b

  • Milestone changed from 4.7 to 4.7.0-pre1

Let's fix it in 4.7.0-pre1

comment:17 Changed 10 years ago by slavazanko

  • Keywords vote-slavazanko added

comment:18 Changed 10 years ago by styx

  • Keywords vote-styx approved added; review removed

comment:19 Changed 10 years ago by andrew_b

  • Status changed from accepted to testing
  • Keywords commited-master added; vote-slavazanko vote-styx approved removed
  • Resolution set to fixed
  • Description modified (diff)

comment:20 Changed 10 years ago by andrew_b

  • Status changed from testing to closed

comment:21 Changed 10 years ago by andrew_b

  • Description modified (diff)

Merged to master.
Initial changeset:5a67008194a16d3dde24e385d7ab0a6adaf6bf69
Final changeset:b72e83193ad43526b0a6fd34dd4b3f407656b196

git log --pretty=oneline d5f1442..b72e831
Note: See TracTickets for help on using tickets.